Bug 1254199 - GOA account Mail part lost on its disable/enable
GOA account Mail part lost on its disable/enable
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
7.2
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks: 1278701
  Show dependency treegraph
 
Reported: 2015-08-17 08:22 EDT by Vadim Rutkovsky
Modified: 2015-11-19 02:59 EST (History)
2 users (show)

See Also:
Fixed In Version: evolution-data-server-3.12.11-22.el7
Doc Type: Bug Fix
Doc Text:
Cause: could not enable GOA configured account Mail part again Consequence: a GOA account had been configured, evolution-data-server picked its enabled parts and offered them to clients. Once the Mail part was disabled, it's re-enable didn't provide the Mail part to the clients again, due to deleted underlying .source files. Fix: File system change notifications are processed properly now, no delete is done (file modification generated delete & create events) Result: Mail part (or even other parts) can be disabled and enabled multiple times without losing them.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:59:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 751657 None None None Never

  None (edit)
Description Vadim Rutkovsky 2015-08-17 08:22:33 EDT
Filed from caserun (https://tcms.engineering.redhat.com/run/257247/)

Version-Release number of selected component (if applicable):
RHEL-7.2-20150806.1

Steps to Reproduce: 
Note: make sure you have evolution-ews installed and restart service
evolution-source-registry if necessary (that is, run `pkill -f evolution`
before restarting evolution).

 1. open control-center
 2. go to Online Accounts panel
 3. click '+'
 4. choose Google and double click it
 5. add credentials for exchange account as listed in document
 6. open Evolution
 7. disable account in gnome online accounts
 8. there should be no mail account in mail folder


 1. go back to gnome online accounts controls and turn mail back on
 2. compose mail adressed to exchange account



Actual results: 
No new evolution exchange account appears

Expected results:
mail account should be shown in Evolution's accounts and mail should be
succesfully sent and received back, too.

Exchange 2010 used, see http://wiki.test.redhat.com/Desktop/OnlineAccounts#MSExchange2010
Comment 1 Vadim Rutkovsky 2015-08-17 08:23:34 EDT
Package versions: 
evolution-data-server-3.12.11-21.el7.x86_64
gnome-online-accounts-3.14.4-2.el7.x86_64
evolution-3.12.11-14.el7.x86_64
Comment 2 Milan Crha 2015-08-17 10:10:35 EDT
I guess this is related to an upstream bug [1]. I'll backport that change, together with the change for an upstream bug [2], which is related.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=751657
[2] https://bugzilla.gnome.org/show_bug.cgi?id=752114
Comment 4 Vadim Rutkovsky 2015-09-07 07:19:58 EDT
Verified on evolution-3.12.11-15.el7.x86_64 and evolution-data-server-3.12.11-23.el7.x86_64
Comment 5 Milan Crha 2015-11-06 06:52:34 EST
This change has a regression in folks `make check`, see bug #1278701 for more information.
Comment 6 errata-xmlrpc 2015-11-19 02:59:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2226.html

Note You need to log in before you can comment on or make changes to this bug.