Bug 1278701 - missing chunk for initialization of the hash table and a mutex
missing chunk for initialization of the hash table and a mutex
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: evolution-data-server (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Milan Crha
Desktop QE
:
Depends On: 1254199
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-06 03:40 EST by Tomas Pelka
Modified: 2016-11-03 20:24 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-data-server-3.12.11-25.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 20:24:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the missing chunk (774 bytes, patch)
2015-11-06 07:00 EST, Milan Crha
no flags Details | Diff

  None (edit)
Description Tomas Pelka 2015-11-06 03:40:41 EST
Description of problem:
Folks eds test get stuck, not sure what is wrong but when I try to run the single binary e.g. ./add-contacts-stress-test I can see

** (/home/tpelka2/rpmbuild/BUILD/folks-0.10.1/tests/eds/.libs/lt-add-contacts-stress-test:24317): DEBUG: test-case.vala:138: setting up in transient directory /tmp/folks-test.DlbSZi
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
Unable to reload configuration: Failed to open "/tmp/g-test-dbus-DHDM7X": No such file or directory
/AddContactsStressTestTests/stress testing adding (1000) contacts to e-d-s : Activating service name='org.gnome.evolution.dataserver.Sources3'
Successfully activated service 'org.gnome.evolution.dataserver.Sources3'

(evolution-source-registry:24348): GLib-CRITICAL **: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed

(evolution-source-registry:24348): GLib-CRITICAL **: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed

(evolution-source-registry:24348): GLib-CRITICAL **: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed

(evolution-source-registry:24348): GLib-CRITICAL **: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed

(evolution-source-registry:24348): GLib-CRITICAL **: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed

(evolution-source-registry:24348): GLib-CRITICAL **: g_hash_table_insert_internal: assertion 'hash_table != NULL' failed

(evolution-source-registry:24348): GLib-CRITICAL **: g_hash_table_foreach: assertion 'hash_table != NULL' failed

(evolution-source-registry:24348): GLib-CRITICAL **: g_hash_table_destroy: assertion 'hash_table != NULL' failed


Version-Release number of selected component (if applicable):
folks-0.10.1-1.el7

How reproducible:
100%

Steps to Reproduce:
1. rebuild folks
2. make check
3.

Actual results:
see description

Expected results:
should pass, like other tests

Additional info:
Comment 1 Tomas Pelka 2015-11-06 06:31:19 EST
Possible bug in eds, Milan partially confirmed.
Comment 2 Milan Crha 2015-11-06 06:53:40 EST
I'm moving this to evolution-data-server, where the core issue is. I missed one chunk when backporting a patch for bug #1254199. It's about all those critical warnings from g_hash_table_...() calls.
Comment 3 Milan Crha 2015-11-06 07:00 EST
Created attachment 1090648 [details]
the missing chunk

for evolution-data-server;

This is the missing chunk; as can be seen, an initialization of the hash table and a mutex had been missing.

From what I read in the glib2 sources, the evolution-source-registry won't crash due to this, the mutex is initialized on demand. The critical warnings about g_hash_table_...() calls are due to the hash_table being a NULL pointer. This can have some side-effects, like in the case of the folks' `make check`, but otherwise no harm like the crash.

The first time there's recognized a source change in the file system it prints the errors, then the missing hash table is created again, thus it starts working as expected after that.
Comment 8 errata-xmlrpc 2016-11-03 20:24:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2206.html

Note You need to log in before you can comment on or make changes to this bug.