This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1254203 - File/Folder manipulation on FTP remote location causes nautilus to crash
File/Folder manipulation on FTP remote location causes nautilus to crash
Status: CLOSED DUPLICATE of bug 1254161
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nautilus (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Carlos Soriano
Desktop QE
:
Depends On:
Blocks: 1295396 1297830
  Show dependency treegraph
 
Reported: 2015-08-17 08:26 EDT by Martin Simon
Modified: 2016-03-08 11:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-29 07:41:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Simon 2015-08-17 08:26:50 EDT
Description of problem:
Manipulation of file/folder on FTP remote location causes crash, but the action is executed. I tried to create folder, delete it and paste from local folder

Version-Release number of selected component (if applicable):
nautilus-3.14.3-3.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Connect to unsecured FTP remote location in nautilus
2. After the connection is established, in nautilus window right-click to spare area to get context menu and select New folder

Actual results:
crash, new folder is created

Expected results:
no crash, new folder is created

Additional info:
Backtrace after abort:
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff49fdf1b in g_type_check_instance_cast (type_instance=0xb2b310, 
    iface_type=iface_type@entry=10963216) at gtype.c:4014
4014		  is_instantiatable = node && node->is_instantiatable;
(gdb) bt
#0  0x00007ffff49fdf1b in g_type_check_instance_cast (type_instance=0xb2b310, iface_type=iface_type@entry=10963216) at gtype.c:4014
#1  0x00000000004749f6 in nautilus_window_on_undo_changed (manager=<optimized out>, window=0xaf03a0) at nautilus-window.c:1512
#5  0x00007ffff49f572f in <emit signal ??? on instance 0xa1db20 [NautilusFileUndoManager]> (instance=<optimized out>, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3365
    #2  0x00007ffff49dbde8 in g_closure_invoke (closure=0xb37820, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=0x7fffffffdac0, invocation_hint=invocation_hint@entry=0x7fffffffda60)
    at gclosure.c:768
    #3  0x00007ffff49ed9b1 in signal_emit_unlocked_R (node=node@entry=0xa802a0, detail=detail@entry=0, instance=instance@entry=0xa1db20, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffffffdac0) at gsignal.c:3623
    #4  0x00007ffff49f5471 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fffffffdc40) at gsignal.c:3309
#6  0x00000000004d2d28 in nautilus_file_undo_manager_set_action (info=<optimized out>) at nautilus-file-undo-manager.c:245
#7  0x00000000004a8164 in finalize_common (common=common@entry=0xc33000)
    at nautilus-file-operations.c:974
#8  0x00000000004a8f2c in create_job_done (user_data=0xc33000)
    at nautilus-file-operations.c:5965
#9  0x00007ffff4c7ba2f in mainloop_proxy_func (data=0x7fffb8005a20)
    at gioscheduler.c:200
#10 0x00007ffff46de79a in g_main_context_dispatch (context=0x792200)
    at gmain.c:3109
#11 0x00007ffff46de79a in g_main_context_dispatch (context=context@entry=0x792200) at gmain.c:3708
#12 0x00007ffff46deae8 in g_main_context_iterate (context=context@entry=0x792200, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>)
    at gmain.c:3779
#13 0x00007ffff46deb9c in g_main_context_iteration (context=0x792200, 
    context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3840
#14 0x00007ffff4cc1f24 in g_application_run (application=0x76a120 [NautilusApplication], argc=argc@entry=1, argv=argv@entry=0x7fffffffdfe8)
    at gapplication.c:2282
#15 0x000000000042a0fb in main (argc=1, argv=0x7fffffffdfe8)
    at nautilus-main.c:103
Comment 1 Martin Simon 2015-08-18 04:20:09 EDT
I've observed very similar bug when manipulating (rename, delete) with file/folder on samba remote location. If the samba case is not the same bug as this one, let me know to create separate bug report.

Backtrace from segfault after renaming folder on samba remote location:
Program received signal SIGSEGV, Segmentation fault.
0x00007ffff49fdf1b in g_type_check_instance_cast (type_instance=0xb2e2f0, 
    iface_type=iface_type@entry=10978544) at gtype.c:4014
4014		  is_instantiatable = node && node->is_instantiatable;
(gdb) bt
#0  0x00007ffff49fdf1b in g_type_check_instance_cast (type_instance=0xb2e2f0, iface_type=iface_type@entry=10978544) at gtype.c:4014
#1  0x00000000004749f6 in nautilus_window_on_undo_changed (manager=<optimized out>, window=0xaf2380)
    at nautilus-window.c:1512
#5  0x00007ffff49f572f in <emit signal ??? on instance 0x9f89e0 [NautilusFileUndoManager]> (instance=<optimized out>, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3365
    #2  0x00007ffff49dbde8 in g_closure_invoke (closure=0xb39dd0, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=0x7fffffffd970, invocation_hint=invocation_hint@entry=0x7fffffffd910) at gclosure.c:768
    #3  0x00007ffff49ed9b1 in signal_emit_unlocked_R (node=node@entry=0xa834d0, detail=detail@entry=0, instance=instance@entry=0x9f89e0, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffffffd970) at gsignal.c:3623
    #4  0x00007ffff49f5471 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fffffffdaf0) at gsignal.c:3309
#6  0x00000000004d2d28 in nautilus_file_undo_manager_set_action (info=<optimized out>)
    at nautilus-file-undo-manager.c:245
#7  0x00000000004b70e7 in nautilus_file_operation_free (op=op@entry=0x808f70) at nautilus-file.c:1674
#8  0x00000000004be7c9 in nautilus_file_operation_complete (op=op@entry=0x808f70, result_file=result_file@entry=0x0, error=<optimized out>) at nautilus-file.c:1700
#9  0x00000000004bf04c in rename_get_info_callback (source_object=<optimized out>, res=<optimized out>, callback_data=0x808f70) at nautilus-file.c:1767
#10 0x00007ffff4c8ef47 in g_simple_async_result_complete (simple=0xb83b50 [GSimpleAsyncResult])
    at gsimpleasyncresult.c:763
#11 0x00007fffe2f2e210 in query_info_async_cb () at /usr/lib64/gio/modules/libgvfsdbus.so
#12 0x00007ffff4c8ef47 in g_simple_async_result_complete (simple=0x7fffc40079c0 [GSimpleAsyncResult])
    at gsimpleasyncresult.c:763
#13 0x00007ffff4cf5231 in reply_cb (connection=<optimized out>, res=<optimized out>, user_data=0x7fffc40079c0) at gdbusproxy.c:2623
#14 0x00007ffff4c8ef47 in g_simple_async_result_complete (simple=0x7fffc4007aa0 [GSimpleAsyncResult])
    at gsimpleasyncresult.c:763
#15 0x00007ffff4cea322 in g_dbus_connection_call_done (source=<optimized out>, result=<optimized out>, user_data=0xf17860) at gdbusconnection.c:5497
#16 0x00007ffff4c8ef47 in g_simple_async_result_complete (simple=0x7fffdc0032e0 [GSimpleAsyncResult])
    at gsimpleasyncresult.c:763
#17 0x00007ffff4c8efa9 in complete_in_idle_cb (data=<optimized out>) at gsimpleasyncresult.c:775
#18 0x00007ffff46de79a in g_main_context_dispatch (context=0x792200) at gmain.c:3109
#19 0x00007ffff46de79a in g_main_context_dispatch (context=context@entry=0x792200) at gmain.c:3708
#20 0x00007ffff46deae8 in g_main_context_iterate (context=context@entry=0x792200, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3779
#21 0x00007ffff46deb9c in g_main_context_iteration (context=0x792200, 
    context@entry=0x0, may_block=may_block@entry=1) at gmain.c:3840
#22 0x00007ffff4cc1f24 in g_application_run (application=0x76a120 [NautilusApplication], argc=argc@entry=1, argv=argv@entry=0x7fffffffdfd8) at gapplication.c:2282
#23 0x000000000042a0fb in main (argc=1, argv=0x7fffffffdfd8) at nautilus-main.c:103
Comment 3 Carlos Soriano 2016-01-29 07:41:13 EST

*** This bug has been marked as a duplicate of bug 1254161 ***

Note You need to log in before you can comment on or make changes to this bug.