Bug 125422 - rename of kernel-source to kernel-sourcecode at build 422
rename of kernel-source to kernel-sourcecode at build 422
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-06 17:52 EDT by Lane Inman
Modified: 2015-01-04 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-19 23:32:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lane Inman 2004-06-06 17:52:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.6)
Gecko/20040510

Description of problem:
Breaks upgrade.... Not sure why you did it, but last two test builds
have had the new name (kernel-sourcecode vs. kernel-source)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. download kernel-sourcecode vs. kernel-source
    

Additional info:

Not sure why you changed this name, I did not go through massive email
lists to determine if it was predetermined, but using yum or even
up2date does not upgrade the kernel-source when the kernel is upgraded.
Comment 1 Barry K. Nathan 2004-06-08 21:41:17 EDT
The updated kernel packages change the kernel-source arch, from i386
or x86_64 or whatever, to noarch. This was making up2date and yum
explode for some people, thus the name change to prevent that.
Comment 2 Joseph M. Brutto 2004-06-14 11:03:53 EDT
I just updated FC2 with up2date to use 2.6.6-1.427.
As stated above, the source did not get updated.

I downloaded and installed the kernel-sourcecode-2.6.6-1.427.noarch.rpm

On the next kernel release that is recognized by up2date, does anyone
know if it will also pick up the updated kernel source?
Comment 3 Barry K. Nathan 2004-06-14 17:44:43 EDT
up2date should pick up the updated kernel source next time, yes
Comment 4 Marc Williams 2004-06-14 22:51:03 EDT
I just manually updated kernel-source since up2date didn't see
kernel-source.  See the thread here:
http://www.redhat.com/archives/fedora-list/2004-June/msg03786.html

Only thing is, I stumbled across it by accident.  I wonder how many
people have kernel-source but have no idea that there are updates
because up2date doesn't find the new name.
Comment 5 Marc Williams 2004-06-14 22:52:52 EDT
Oops.  That first sentence should be:
I just manually updated kernel-source since up2date didn't see
kernel-sourcecode.
Comment 6 Sitsofe Wheeler 2004-06-16 07:12:24 EDT
Can a warning about this be put into the changelog or rpm information?
I only just stumbled across this bug after looking at a yum repository
and spotting the name change after wondering why the kernel source
wasn't being pulled in by a nightly update. 

On the mailing list someone suggests yum upgrade. Yes this pull in
kernel-sourcecode but yum upgrade is broken and tries to suck in
packages to update to compat-db which it mistakenly thinks obsoletes
db4 (bug 123911 possibly won't be fixed in FC2). It's also a shame
that the little RHN applet doesn't warn you about this problem
(perhaps I should spin off a bug there).
Comment 7 Dave Jones 2004-11-19 23:32:47 EST
its a bit late to fix this in any way now.
(And for FC3 it went away completely anyway)

Note You need to log in before you can comment on or make changes to this bug.