Bug 1254228 - rhevm-log-collector is missing sos dependency on RHEL 6.7
Summary: rhevm-log-collector is missing sos dependency on RHEL 6.7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-log-collector
Version: 3.5.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Sandro Bonazzola
QA Contact: Gonza
URL:
Whiteboard:
Depends On:
Blocks: 1254526
TreeView+ depends on / blocked
 
Reported: 2015-08-17 13:11 UTC by Ying Cui
Modified: 2020-09-10 09:24 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
This fix resolves dependencies which allow rhevm-log-collector to correctly handle sos 3.2 shipped within Red Hat Enterprise Linux 6.7.
Clone Of:
: 1254526 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:00:37 UTC
oVirt Team: Integration
Target Upstream Version:
lsvaty: testing_plan_complete-


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0392 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2016-03-10 00:19:00 UTC
oVirt gerrit 45005 master MERGED packaging: spec: add missing require on sos Never
oVirt gerrit 45006 ovirt-log-collector-3.6 MERGED packaging: spec: add missing require on sos Never

Description Ying Cui 2015-08-17 13:11:09 UTC
Description:
sos rpm is not built in rhevm-appliance which is required by rhevm-log-collector

# rhevm-log-collector
Traceback (most recent call last):
  File "/usr/bin/rhevm-log-collector", line 39, in <module>
    import sos
ImportError: No module named sos

Version:
rhevm-appliance-20150727.0-1

Test steps:
1. Installed RHEV-H
2. Setup Hosted-Engine on RHEV-H by rhevm-appliance ova
3. login rhevm-appliance ova to setup rhevm successful.
4. Try to collect all log in rhevm, but failed, here need to yum install sos in RHEL channel.

Actual result:
# rhevm-log-collector -h
Traceback (most recent call last):
  File "/usr/bin/rhevm-log-collector", line 39, in <module>
    import sos
ImportError: No module named sos

Expected result:
sos rpm should be included in rhevm-appliance as default.

Comment 1 Ying Cui 2015-08-17 13:26:15 UTC
After confirmed with fabian over IRC, here user can subscribe RHEL and RHEV channle on rhevm-appliance, then user can install sos by themselves.

I lower the severity. 

and probably we can consider close it.

Comment 2 Fabian Deutsch 2015-08-17 13:34:44 UTC
This can be easily fixed by installing rhevm-log-collector-sos-plugins , which should pull in the right dependency.

Comment 3 Fabian Deutsch 2015-08-17 13:37:50 UTC
Moving this over to the log-collector, as this looks to be a missing dependency after all.

If we install the log-collector, then sos should be installed as well, if it's required.

Comment 4 Sandro Bonazzola 2015-08-17 13:41:05 UTC
On RHEL 6.6 the dependency is pulled in by rhevm-log-collector-sos-plugins but it is missing in rhevm-log-collector on 6.7 where rhevm-log-collector-sos-plugins must not be installed.

Comment 8 Gonza 2015-09-14 11:19:51 UTC
Verified with:
rhevm-appliance-20150910.0-1

By default [1] is installed.

# engine-log-collector collect
This command will collect system configuration and diagnostic
information from this system.
The generated archive may contain data considered sensitive and its
content should be reviewed by the originating organization before
being passed to any third party.
No changes will be made to system configuration.
Please provide the REST API password for the admin@internal oVirt Engine user (CTRL+D to skip): 
INFO: Gathering oVirt Engine information...
INFO: Gathering PostgreSQL the oVirt Engine database and log files from localhost...
INFO: No hypervisors were selected, therefore no hypervisor data will be collected.
Creating compressed archive...
INFO: Log files have been collected and placed in /tmp/sosreport-LogCollector-20150914071839.tar.xz.
The MD5 for this file is 25d6a42a7be7313cd91c924700c52cd5 and its size is 7.4M

[1] sos-3.2-28.el6.noarch

Comment 11 errata-xmlrpc 2016-03-09 20:00:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0392.html


Note You need to log in before you can comment on or make changes to this bug.