Bug 1254251 - It's impossible to move Host to another Cluster
It's impossible to move Host to another Cluster
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
high Severity high
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Alexander Wels
Pavel Stehlik
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 09:52 EDT by GenadiC
Modified: 2016-04-19 21:30 EDT (History)
8 users (show)

See Also:
Fixed In Version: 3.6.0-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:30:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen-cast: change Host's Cluster via the Edit Host dialog (1.43 MB, application/ogg)
2015-08-18 07:34 EDT, Einav Cohen
no flags Details
screen-cast: change Host's Cluster via the Cluster 'Guide Me' dialog (1.92 MB, application/ogg)
2015-08-18 07:35 EDT, Einav Cohen
no flags Details
screen-cast: change Host's Cluster via the Data Center 'Guide Me' dialog (2.01 MB, application/ogg)
2015-08-18 07:35 EDT, Einav Cohen
no flags Details

  None (edit)
Description GenadiC 2015-08-17 09:52:25 EDT
Description of problem:
Moving host to another Cluster is stucked 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create additional cluster
2. Try to move host to that cluster
3.

Actual results:
An operation is stucked

Expected results:
Operation should succeed

Additional info:
An action of moving host to different cluster works in Rest API
There is nothing in engine log
Comment 1 Einav Cohen 2015-08-18 07:34:38 EDT
Created attachment 1064291 [details]
screen-cast: change Host's Cluster via the Edit Host dialog
Comment 2 Einav Cohen 2015-08-18 07:35:15 EDT
Created attachment 1064292 [details]
screen-cast: change Host's Cluster via the Cluster 'Guide Me' dialog
Comment 3 Einav Cohen 2015-08-18 07:35:53 EDT
Created attachment 1064293 [details]
screen-cast: change Host's Cluster via the Data Center 'Guide Me' dialog
Comment 4 Einav Cohen 2015-08-18 07:44:17 EDT
Genadi:

- BZ whiteboard should be lowercase ('UX' -> 'ux')

- changing a Host's cluster is in the 'infra' domain of responsibility (changed Whiteboard accordingly). 

- you did not specify how you attempted to change the Host's Cluster - 
via Edit Host? 
Cluster Guide Me -> Select Hosts? 
Data Center Guide Me -> Select Hosts?

- can you please specify the exact 3.6 version that you have tested (as we have introduced some updates and fixes to the Edit Host dialog recently)?

- I've attempted to Edit the Host's Cluster on ~latest master via Edit Host [see attachment 1064291 [details]], via the Cluster's Guide Me [see attachment 1064292 [details]] and via the Data-Center's Guide Me [see attachment 1064293 [details]], all of which completed successfully (pointing out that I chose to not activate the Host after changing its cluster in the Guide Me scenarios). 
If you attempted to change the Host's cluster via a Guide Me dialog: Did you choose to activate the Host? what happens when you are choosing to not activate the Host?
If you haven't done so already: did you test on latest master?
Comment 5 GenadiC 2015-08-18 08:19:40 EDT
I put host to maintenance, then in the edit picked the new cluster
It happens on rhevm-3.6.0-0.11.master.el6.noarch version
Comment 6 Einav Cohen 2015-08-18 10:33:00 EDT
I imagine that this is a "duplicate" of bug 1253694 (can't mark as duplicate, since one is oVirt and the other is RHEV). 

bug 1253694 (and, most likely, this one as well, as they are probably "duplicates") was fixed in https://gerrit.ovirt.org/#/c/44691/, which was merged only after rhevm-3.6.0-0.11.master.el6.noarch was built (rhevm-3.6.0-0.11.master.el6.noarch is based on https://gerrit.ovirt.org/#/c/44664/).
Comment 8 GenadiC 2015-08-31 06:07:33 EDT
Verified in 3.6.0-0.12.master.el6

Note You need to log in before you can comment on or make changes to this bug.