Bug 1254334 - Unreliable cpu detection through glibtop
Unreliable cpu detection through glibtop
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-system-monitor (Show other bugs)
6.7
All Linux
unspecified Severity low
: rc
: ---
Assigned To: David King
Desktop QE
: Reopened
Depends On:
Blocks: 1172231
  Show dependency treegraph
 
Reported: 2015-08-17 14:11 EDT by Helio Chissini de Castro
Modified: 2017-03-21 05:08 EDT (History)
6 users (show)

See Also:
Fixed In Version: gnome-system-monitor-2.28.0-13.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 05:08:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for RHEL 6 Gnome (849 bytes, patch)
2015-08-17 14:11 EDT, Helio Chissini de Castro
no flags Details | Diff

  None (edit)
Description Helio Chissini de Castro 2015-08-17 14:11:30 EDT
Created attachment 1064025 [details]
Patch for RHEL 6 Gnome

glibtop not provides the number of cpus on the machine directly, relying on a list with the current load of each core.

Original code assume that a 0 load core is the end of cpu list, which is invalid in cases of machines with high number of cores, that happens to some cores stay idle with 0 load.

Since this can happens in any core number, if a machine has 192 cores, but the core number 5 has 0 load, then 4 cores will be wrongly reported.

Using standard sysconf api solves the issue in a simple way.
Comment 1 Helio Chissini de Castro 2015-08-17 14:12:40 EDT
Similar bug was opened for RHEL 7.
This one contains the patch for the previous Gnome from RHEL 6

Reference on RHEL 7
https://bugzilla.redhat.com/show_bug.cgi?id=1254332
Comment 6 David King 2016-08-25 12:37:05 EDT
As the patch is already written, this is a very easy fix.
Comment 8 Michael Boisvert 2016-12-20 12:06:16 EST
While testing a multi-core machine with gnome-system-monitor-2.28.0-13.el6, I was able to see the correct amount of cores listed, as well as the idle cores at 0.0%.
Comment 10 errata-xmlrpc 2017-03-21 05:08:16 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0578.html

Note You need to log in before you can comment on or make changes to this bug.