This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1254346 - Satellite6 system not subscribed
Satellite6 system not subscribed
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - Satellite (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: jkim
Tasos Papaioannou
Dan Macpherson
: Triaged
Depends On:
Blocks: qci-sprint-17
  Show dependency treegraph
 
Reported: 2015-08-17 15:33 EDT by Thom Carlin
Modified: 2016-09-13 12:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:21:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-08-17 15:33:09 EDT
Description of problem:

At end of deployment, RHCI Satellite 6 system is not subscribed anywhere.

Version-Release number of selected component (if applicable):

Tech-preview Rc-1

How reproducible:

100%

Steps to Reproduce:
1. Deploy RHCI
2. subscription-manager status
3.

Actual results:

Error

Expected results:

Subscribed successfully to itself or RHN with appropriate repositories enabled.

Additional info:
Comment 9 John Matthews 2016-08-05 09:04:49 EDT
We've added the ability to register to the CDN with fusor-installer.  If a user wants to register to itself, they will need to do this manually after they have the needed content on the Satellite.
Comment 10 Tasos Papaioannou 2016-08-18 17:18:44 EDT
What are the steps to register with fusor-installer? There are no registration-related fields visible in the fusor-installer menu or in fusor-installer --help.
Comment 11 jkim 2016-08-22 14:21:09 EDT
The new option was added to properly register to the CDN. 
https://bugzilla.redhat.com/show_bug.cgi?id=1360855

The option #15 will allow for this during the fusor-installer as shown below

Modify settings as needed, and then proceed with the installation:
1.      Proceed with the values shown
2.           Network interface | em1
3.                    Hostname | sat62fusor.example.com
4.                  IP address | 10.9.45.10
5.                Network mask | 255.255.255.0
6.                Host gateway | 10.9.45.254
7.        DHCP network address | 10.9.45.0
8.            DHCP range start | 10.9.45.11
9.              DHCP range end | 10.9.45.250
10.               DHCP gateway | 10.9.45.254
11.              DNS forwarder | 10.8.104.1
12.                     Domain | example.com
13.              NTP sync host | clock.redhat.com
14.                  Time zone | America/New_York
15.  Register Host For Updates | false
16.       Configure networking | true
17.         Configure firewall | true
18. Cancel installation
15
Register this host with subscription manager to the customer portal for updates
Enter the USERNAME:
Comment 12 Tasos Papaioannou 2016-08-22 15:14:49 EDT
Tested on QCI-1.0-RHEL-7-20160819.t.0. The system is registered and subscribed successfully, but the enabled repositories are not correct:

[root@fusor ~]# yum repolist
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
repo id                                       repo name                                                             status
rhel-7-server-nfv-rpms/7Server/x86_64         Red Hat Enterprise Linux for Real Time for NFV (RHEL 7 Server) (RPMs)     64
rhel-7-server-rpms/7Server/x86_64             Red Hat Enterprise Linux 7 Server (RPMs)                              11,241
rhel-ha-for-rhel-7-server-rpms/7Server/x86_64 Red Hat Enterprise Linux High Availability (for RHEL 7 Server) (RPMs)    224
repolist: 11,529

The required repositories are (see https://access.redhat.com/documentation/en/red-hat-satellite/6.2/paged/installation-guide/chapter-3-installing-satellite-server ):

rhel-7-server-rpms
rhel-server-rhscl-7-rpms
rhel-7-server-satellite-6.2-rpms
Comment 13 jkim 2016-08-22 15:37:25 EDT
Agreed. That issue is tracked here:
https://bugzilla.redhat.com/show_bug.cgi?id=1365509
Comment 16 errata-xmlrpc 2016-09-13 12:21:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.