Bug 1254430 - [New] - glusterfs dead when user creates a rdma volume
Summary: [New] - glusterfs dead when user creates a rdma volume
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: rdma
Version: 3.7.3
Hardware: All
OS: All
urgent
high
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact:
URL:
Whiteboard:
Depends On: 1250189 1250297
Blocks: glusterfs-3.7.9
TreeView+ depends on / blocked
 
Reported: 2015-08-18 07:02 UTC by Mohammed Rafi KC
Modified: 2016-04-19 07:24 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Clone Of: 1250297
Environment:
Last Closed: 2016-04-19 07:24:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Anand Avati 2015-08-18 07:04:18 UTC
REVIEW: http://review.gluster.org/11943 (rdma:restore device linked list structure in case of failure) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Vijay Bellur 2015-09-10 10:47:18 UTC
REVIEW: http://review.gluster.org/11943 (rdma:restore device linked list structure in case of failure) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Vijay Bellur 2016-02-10 06:14:17 UTC
REVIEW: http://review.gluster.org/11943 (rdma:restore device linked list structure in case of failure) posted (#3) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 4 Vijay Bellur 2016-02-22 08:02:13 UTC
COMMIT: http://review.gluster.org/11943 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 605ff4691cc265c5459d77305ef6df777a94ee8f
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Aug 5 12:07:48 2015 +0530

    rdma:restore device linked list structure in case of failure
    
    We maintain a linked list strcture to store device information,
    and maintain head in a ctx variable. A new device will be added
    at the beginning of list. But if the device creation failed, then
    we need to adjust the linked list to proper state.
    
    back port of :
    >Change-Id: I07cefd3b808d8973a915728b3ba7f2955d29c92a
    >BUG: 1250297
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/11829
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    
    
    (cherry picked from commit 7641eb8b469a6dd4db6db59d2a5ef4d5a65e1a61)
    
    Change-Id: I5e7bcdef9402c11a139db8047ae2a9a18cdd8f4e
    BUG: 1254430
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11943
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 5 Kaushal 2016-04-19 07:24:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.