Bug 1254451 - Data Tiering : Some tier xlator_fops translate to the default fops
Data Tiering : Some tier xlator_fops translate to the default fops
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
: Reopened
Depends On:
Blocks: 1254468 1260923
  Show dependency treegraph
 
Reported: 2015-08-18 03:47 EDT by Nithya Balachandran
Modified: 2016-06-16 09:32 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1254468 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:32:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-08-18 03:47:11 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Anand Avati 2015-08-18 04:11:56 EDT
REVIEW: http://review.gluster.org/11948 (cluster/tier : Use dht_* versions for xlator_fops) posted (#1) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 2 Nithya Balachandran 2015-08-18 04:18:08 EDT
This causes issues during file migration as the tier dht layer does not call the dht_* for some fops, because of which the dht specific processing to never happens at the tier layer.
Comment 3 Anand Avati 2015-08-18 04:20:26 EDT
REVIEW: http://review.gluster.org/11948 (cluster/tier : Use dht_* versions for xlator_fops) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 4 Anand Avati 2015-08-18 21:30:54 EDT
COMMIT: http://review.gluster.org/11948 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit a4bbb71e91744ed387606dd4eb5bee55cf86b079
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Aug 18 13:37:12 2015 +0530

    cluster/tier : Use dht_* versions for xlator_fops
    
    The tier xlator was using the default_* versions
    for some xlator_fops. Changed to use the dht_*
    versions for all xlator_fops
    
    Change-Id: I8252fb3911b8a48a55e9eee42b89bd66bbacf799
    BUG: 1254451
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    Reviewed-on: http://review.gluster.org/11948
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 5 Nagaprasad Sathyanarayana 2015-10-25 11:09:29 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 6 Niels de Vos 2016-06-16 09:32:25 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.