Bug 1254468 - Data Tiering : Some tier xlator_fops translate to the default fops
Data Tiering : Some tier xlator_fops translate to the default fops
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nithya Balachandran
bugs@gluster.org
:
Depends On: 1254451
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-08-18 04:21 EDT by Nithya Balachandran
Modified: 2015-10-30 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1254451
Environment:
Last Closed: 2015-09-09 05:39:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nithya Balachandran 2015-08-18 04:21:39 EDT
+++ This bug was initially created as a clone of Bug #1254451 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:



--- Additional comment from Nithya Balachandran on 2015-08-18 04:18:08 EDT ---

This causes issues during file migration as the tier dht layer does not call the dht_* for some fops, because of which the dht specific processing to never happens at the tier layer.

--- Additional comment from Anand Avati on 2015-08-18 04:20:26 EDT ---

REVIEW: http://review.gluster.org/11948 (cluster/tier : Use dht_* versions for xlator_fops) posted (#2) for review on master by N Balachandran (nbalacha@redhat.com)
Comment 1 Anand Avati 2015-08-18 05:39:08 EDT
REVIEW: http://review.gluster.org/11951 (cluster/tier : Use dht_* versions for xlator_fops) posted (#1) for review on release-3.7 by N Balachandran (nbalacha@redhat.com)
Comment 2 Anand Avati 2015-08-19 04:14:18 EDT
COMMIT: http://review.gluster.org/11951 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit b54353ec7e3ceaee1100f3616a6725e3dd67a539
Author: N Balachandran <nbalacha@redhat.com>
Date:   Tue Aug 18 14:15:59 2015 +0530

    cluster/tier : Use dht_* versions for xlator_fops
    
    The tier xlator was using the default_* versions
    for some xlator_fops. Changed to use the dht_*
    versions for all xlator_fops
    
    Change-Id: I8252fb3911b8a48a55e9eee42b89bd66bbacf799
    BUG: 1254468
    Signed-off-by: N Balachandran <nbalacha@redhat.com>
    (cherry picked from commit 0c20107a60726804030f98a7f79b94c677e6a7b6)
    Reviewed-on: http://review.gluster.org/11951
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2015-09-09 05:39:53 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.