Bug 1254555 - [Admin Portal]: Error after clicking on 'Errata' tab - Problem retrieving errata: PROVIDER_FAILURE
[Admin Portal]: Error after clicking on 'Errata' tab - Problem retrieving err...
Status: CLOSED DUPLICATE of bug 1252317
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.6.0
All Linux
high Severity high
: ---
: 3.6.0
Assigned To: Moti Asayag
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 07:50 EDT by Bhushan Barve
Modified: 2016-02-10 14:36 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 09:14:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Errata error (94.28 KB, image/png)
2015-08-18 07:50 EDT, Bhushan Barve
no flags Details
Errata error (46.28 KB, image/png)
2015-08-18 07:52 EDT, Bhushan Barve
no flags Details

  None (edit)
Description Bhushan Barve 2015-08-18 07:50:10 EDT
Created attachment 1064295 [details]
Errata error

Description of problem: An error is displayed after clicking on 'Errata' tab under 'System' pane in LHS. Following error message gets displayed on the screen- 'Problem retrieving errata: PROVIDER_FAILURE'. Please refer attached screenshot.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.6.0-0.11.master.el6 

How reproducible:
always

Steps to Reproduce:
1. login to RHEV Admin portal
2. click on 'Errata' tab under 'System' tree in LHS.
3.

Actual results:
Folowing error gets displayed- Problem retrieving errata: PROVIDER_FAILURE

Expected results:
There should not be any error

Additional info:
Comment 1 Bhushan Barve 2015-08-18 07:52:39 EDT
Created attachment 1064297 [details]
Errata error
Comment 2 Einav Cohen 2015-08-19 08:36:26 EDT
Bhushan, can you please attach the engine.log?
[not sure if this is a GUI issue or a backend issue]
Comment 3 Moti Asayag 2015-08-19 08:56:49 EDT
Bhushan, do you have does 'tests' host provider represents Katello/Satellite to which the ovirt engine server is registered ?
Comment 4 Bhushan Barve 2015-08-20 03:28:05 EDT
Moti, I'm seeing following error in hosts->general->errata section: 
Problem retrieving errata: The engine is not associated with a Foreman/Satellite provider. No errata for the engine are available.

Is this the same thing you are asking about?
Comment 5 Moti Asayag 2015-08-23 03:45:45 EDT
(In reply to Bhushan Barve from comment #4)
> Moti, I'm seeing following error in hosts->general->errata section: 
> Problem retrieving errata: The engine is not associated with a
> Foreman/Satellite provider. No errata for the engine are available.
> 
> Is this the same thing you are asking about?

No, I was referring to the system errata on the left system tree.

Could you check if you're able to retrieve any errata via the rest api by querying:

  /api/hosts/{host:id}/katelloerrata

If you're able to get any info from that URL, it is a UI issue.

Are the hosts registered to Katello/Satellite server ?
Comment 6 Bhushan Barve 2015-08-24 09:14:27 EDT
Closing it as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1252317.
Same issue is mentioned there in the comment 1 of that bug -
'Another issue we found is that if a VM is up, ERRATA information isn't shown. This will be fixed as part of this bug.'

*** This bug has been marked as a duplicate of bug 1252317 ***

Note You need to log in before you can comment on or make changes to this bug.