Bug 1254578 - unexpected "Registering to: hostname:port/prefix" when calling subscription-manager environments
unexpected "Registering to: hostname:port/prefix" when calling subscription-m...
Status: CLOSED DUPLICATE of bug 1254349
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: vritant
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 08:41 EDT by John Sefler
Modified: 2015-08-27 14:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 14:19:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2015-08-18 08:41:13 EDT
Description of problem:
As a side affect of https://bugzilla.redhat.com/show_bug.cgi?id=985157#c13 we now get an additional stdout message when executing subscription-manager environments module stating ...
Registering to: hostname:port/prefix

Version-Release number of selected component (if applicable):
[root@ibm-p8-kvm-04-guest-06 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.51.4-1
subscription management rules: 5.15
subscription-manager: 1.15.9-6.el7
python-rhsm: 1.15.4-2.el7

How reproducible:


Steps to Reproduce:
[root@ibm-p8-kvm-04-guest-06 ~]# subscription-manager config --server.hostname=subscription.rhn.stage.redhat.com --server.port=443 --server.prefix=/subscription
[root@ibm-p8-kvm-04-guest-06 ~]# 
[root@ibm-p8-kvm-04-guest-06 ~]# subscription-manager environments
Registering to: subscription.rhn.stage.redhat.com:443/subscription <=== UNEXPECTED
Username: stage_test_12
Password: 
Error: Server does not support environments.
[root@ibm-p8-kvm-04-guest-06 ~]#

Actual results:
  above

Expected results:
  the stdout from calls to the environments module should exclude "Registering to:" message

Additional info:
Comment 1 vritant 2015-08-27 14:19:10 EDT

*** This bug has been marked as a duplicate of bug 1254349 ***

Note You need to log in before you can comment on or make changes to this bug.