Bug 1254349 - unexpected "Registering to: hostname:port/prefix" when calling subscription-manager identity --regenerate --force
unexpected "Registering to: hostname:port/prefix" when calling subscription-m...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: vritant
John Sefler
:
: 1254353 1254578 1256960 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-17 15:46 EDT by John Sefler
Modified: 2015-11-19 06:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:50:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2015-08-17 15:46:52 EDT
Description of problem:
As a side affect of https://bugzilla.redhat.com/show_bug.cgi?id=985157#c13 we now get an additional stdout message when calling subscription-manager identity --regenerate" stating ...
Registering to: hostname:port/prefix

Although the extra stdout message is harmless, it is a little misleading because the system is already registered.


Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.6-1
subscription management rules: 5.16
subscription-manager: 1.15.9-6.el7
python-rhsm: 1.15.4-2.el7


How reproducible:


Steps to Reproduce:
[root@jsefler-7 ~]# subscription-manager register --serverurl=subscription.rhn.stage.redhat.com:443/subscription
Registering to: subscription.rhn.stage.redhat.com:443/subscription
Username: stage_auto_testuser1
Password: 
The system has been registered with ID: 258d9752-ee44-413a-bc07-88a748d4133c 
[root@jsefler-7 ~]# 
[root@jsefler-7 ~]# subscription-manager identity --regenerate --force
Registering to: subscription.rhn.stage.redhat.com:443/subscription <===== UNEXPECTED
Username: stage_auto_testuser1
Password: 
Identity certificate has been regenerated.
[root@jsefler-7 ~]#


Actual results:
  stdout from identity includes "Registering to:"...

Expected results:
  stdout from identity should exclude "Registering to:"...

Additional info:
Comment 1 vritant 2015-08-27 14:17:55 EDT
*** Bug 1256960 has been marked as a duplicate of this bug. ***
Comment 2 vritant 2015-08-27 14:19:10 EDT
*** Bug 1254578 has been marked as a duplicate of this bug. ***
Comment 3 vritant 2015-08-27 14:20:14 EDT
*** Bug 1254353 has been marked as a duplicate of this bug. ***
Comment 7 Chris Rog 2015-09-02 13:22:05 EDT
commit 1dd77a0892bc814e62a07025d9f9714da4362ceb
Author: Vritant Jain <vrjain@redhat.com>
Date:   Thu Aug 27 14:24:30 2015 -0400

    1254349: move Resgistering to message
Comment 9 Shwetha Kallesh 2015-09-03 05:09:39 EDT
Marking verified!!

[root@dhcp35-24 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.6-1
subscription management rules: 5.16
subscription-manager: 1.15.9-8.el7
python-rhsm: 1.15.4-4.el7

[root@dhcp35-24 ~]# subscription-manager register  --org admin --serverurl 10.70.35.150:8443/candlepin
Registering to: 10.70.35.150:8443/candlepin
Username: admin
Password: 
The system has been registered with ID: 37a6cef2-3622-4816-8089-639a89773cbd 
[root@dhcp35-24 ~]# subscription-manager identity --regenerate --force
Username: admin
Password: 
Identity certificate has been regenerated.
Comment 10 errata-xmlrpc 2015-11-19 06:50:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.