Bug 125472 - distutils.sysconfig.get_python_lib() out of sync with install paths
Summary: distutils.sysconfig.get_python_lib() out of sync with install paths
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
(Show other bugs)
Version: 2
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords: Patch
Depends On:
Blocks: 127614
TreeView+ depends on / blocked
 
Reported: 2004-06-07 20:18 UTC by Ville Skyttä
Modified: 2007-11-30 22:10 UTC (History)
3 users (show)

Fixed In Version: 2.3.4-5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-04 16:45:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Don't hardcode lib64 for pure-python get_python_lib() (585 bytes, patch)
2004-06-07 20:29 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2004-06-07 20:18:49 UTC
See https://bugzilla.fedora.us/show_bug.cgi?id=1416#c21 and later
comments.

distutils.sysconfig.get_python_lib() seems to be out of sync with
distutils.command.install.py on 64-bit platforms.

The culprit seems to be python-2.3.2-lib64.patch which hardcodes lib64
for non-arch-specific libs in distutils.sysconfig.

Will attach a patch for review.

Comment 1 Ville Skyttä 2004-06-07 20:29:48 UTC
Created attachment 100942 [details]
Don't hardcode lib64 for pure-python get_python_lib()

Untested patch, but seems correct to me.  This should be applied after applying
python-2.3.2-lib64.patch.

Comment 2 Ville Skyttä 2004-06-28 18:30:32 UTC
Any news about this one?

Comment 3 Ville Skyttä 2004-06-29 22:19:55 UTC
Justin, I figured you might be interested in this, and could perhaps test?

Comment 4 Mihai Ibanescu 2004-06-29 22:31:32 UTC
Oh, sorry.
I didn't really had a chance to take a look on a 64-bit machine. Will
try ASAP.
If someone else can confirm the patch looks ok, I'll check it in.

Comment 5 Ville Skyttä 2004-07-21 16:17:45 UTC
misa: ping: any progress on this one?

Comment 6 Mihai Ibanescu 2004-07-29 21:57:55 UTC
Argh, I have a list of python bugs I try to check in at the same time.
I'll get to it tonight.

Comment 7 Mihai Ibanescu 2004-07-29 23:42:48 UTC
python-2.3.4-5 should have this fixed.


Note You need to log in before you can comment on or make changes to this bug.