Bug 127614 - Bogus hardcoded python site-packages dir
Summary: Bogus hardcoded python site-packages dir
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ethereal   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords: EasyFix, Patch
: 122058 (view as bug list)
Depends On: 125472
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-10 23:31 UTC by Ville Skyttä
Modified: 2015-03-05 01:14 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 14:49:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix python site-packages dir location (1.55 KB, patch)
2004-07-10 23:33 UTC, Ville Skyttä
no flags Details | Diff

Description Ville Skyttä 2004-07-10 23:31:27 UTC
Ethereal installs some Python stuff into
/usr/lib/python2.2/site-packages, where 2.2 is hardcoded, and we have
2.3 already.  Will attach a patch against current rawhide.

Note: in order to produce expected results when/if this fix is applied
and the resulting package built on 64-bit archs, bug 125472 should be
fixed first.

On the other hand, the installed python files look like ethereal
development files, and depend on omniidl from omniORB, which AFAICS
isn't available in Fedora Core; so perhaps the python files could just
be dropped altogether...

Comment 1 Ville Skyttä 2004-07-10 23:33:00 UTC
Created attachment 101782 [details]
Fix python site-packages dir location

Comment 2 Miloslav Trmac 2004-07-11 13:35:30 UTC
*** Bug 122058 has been marked as a duplicate of this bug. ***

Comment 3 Phil Knirsch 2004-07-14 14:49:42 UTC
OK, despite omniidl from omniORB not being in Fedore Core i fixed the
installation, maybe someone installs those package manually and hopes
ethereal to work with the python modules. ;-)

Fixed in ethereal-0.10.5-2 and later available via development.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.