Bug 1254748 - ovirt 3.6 beta 2: The engine VM not present in webui
ovirt 3.6 beta 2: The engine VM not present in webui
Status: CLOSED DUPLICATE of bug 1274294
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
x86_64 Linux
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Roy Golan
Pavel Stehlik
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-18 14:44 EDT by wodel
Modified: 2016-02-10 15:18 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-26 04:47:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑3.6.0?
ylavi: planning_ack?
ylavi: devel_ack?
ylavi: testing_ack?


Attachments (Terms of Use)
ovirt logs (450.97 KB, application/x-gzip)
2015-08-20 13:49 EDT, wodel
no flags Details

  None (edit)
Description wodel 2015-08-18 14:44:59 EDT
Description of problem:

I did several installations of the ovirt hosted-engine using NFS4 as storage for the engine's VM and for all data domains (data, iso and export).

At the end of the installation, the engine VM is started but it is not present on webui, even after adding data domain and bringing up the Datacenter.

I disabled firewalling and SELinux everywhere, but it didn't change anything.

Version-Release number of selected component (if applicable):

3.6 beta 2

How reproducible:

always

Steps to Reproduce:
1. Install ovirt hosted-engine


Actual results:

No engine VM on webui 

Expected results:

The engine VM present on the webui

Additional info:
Comment 1 Roy Golan 2015-08-19 09:15:02 EDT
Please supply engine logs logcollector from the host. Thanks.
Comment 2 wodel 2015-08-20 13:49:08 EDT
Created attachment 1065352 [details]
ovirt logs

Hi, 

here some logs of ovirt, from the hypervisor and from the VM engine.

Could you explain what is "logcollector"?

Regards
Comment 3 Roy Golan 2015-09-17 07:22:52 EDT
Sorry I meant sosreport but anyway the logs which you supplied are perfect.

From the engine.log I see the engine is trying to make the host SPM. After that the log is truncated. 

If the problem persist, can you reattach the current engine log ?
Comment 4 wodel 2015-09-17 08:19:54 EDT
Hi,

I did retest with ovirt 3.6 beta 5, still the same problem, no VM engine on webui,

however, this time I tested with the Beta4, then I just updated packages, I didn't redeploy from the beginning, just dnf update on hypervisor, restart vdsmd ovirt-ha-agent and ovirt-ha-brocker and the same on the VM engine with engine-setup after update.


The thing is, every time I try to added the hosted_storage to the datacenter (Default), the VM engine crashs completely, I think this is why the engine's  log is truncated.
Comment 5 ian 2015-09-18 05:22:56 EDT
I am having the same problem. Let me know if need anything from me.
Comment 6 Roy Golan 2015-10-11 08:32:18 EDT
(In reply to wodel from comment #4)
> Hi,
> 
> I did retest with ovirt 3.6 beta 5, still the same problem, no VM engine on
> webui,
> 
> however, this time I tested with the Beta4, then I just updated packages, I
> didn't redeploy from the beginning, just dnf update on hypervisor, restart
> vdsmd ovirt-ha-agent and ovirt-ha-brocker and the same on the VM engine with
> engine-setup after update.
> 
> 
> The thing is, every time I try to added the hosted_storage to the datacenter
> (Default), the VM engine crashs completely, I think this is why the engine's
> log is truncated.


The import causing the crash is now fixed, see bug 1261996 (you'll have it in nightly build)

After that you will be able to import the domain and see the VM.

If you can try the nightly it will be great.
Comment 7 wodel 2015-10-11 16:26:32 EDT
Hi,

It didn't work for me, 

- I added ovirt 3.6 snapshot to my repo
- I installed the most recent packages.
- Execute engine-setup
- Import hosted_storage -> VM crashes 

When restarted the hosted_storage still unattached.

I tried to do the same using the REST api, the same result.

All I got on webui is this message before collapse : Uncaught exception occurred. Please try reloading the page. Details: Index: 0, Size: 0 

May be I am not using the minimum requirements to test this version !!!

- one hypervisor
- one NIC card
- FC22 for both hypervisor and VM engine
- NFS 4 storage
- 2Gb RAM for the VM engine

this is my nfs4 config
/home/ovirt             192.168.1.0/24(fsid=0,rw,insecure,sync,wdelay,no_subtree_check,all_squash,anonuid=36,anongid=36)
/home/ovirt/vmengine    192.168.1.0/24(rw,insecure,sync,wdelay,no_subtree_check,nohide,all_squash)
/home/ovirt/export      192.168.1.0/24(rw,insecure,sync,wdelay,no_subtree_check,nohide,all_squash)
/home/ovirt/iso         192.168.1.0/24(rw,insecure,sync,wdelay,no_subtree_check,nohide,all_squash)
/home/ovirt/vms         192.168.1.0/24(rw,insecure,sync,wdelay,no_subtree_check,nohide,all_squash)
Comment 8 Red Hat Bugzilla Rules Engine 2015-10-19 06:52:01 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Sandro Bonazzola 2015-10-26 08:29:14 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 10 Sandro Bonazzola 2015-11-05 03:20:42 EST
oVirt 3.6.0 has been released on November 4th, re-targeting to 4.0 since this bug has been marked with severity < high
Comment 11 Red Hat Bugzilla Rules Engine 2015-11-16 09:07:53 EST
This bug is flagged for 3.6, yet the milestone is for 4.0 version, therefore the milestone has been reset.
Please set the correct milestone or add the flag.
Comment 12 Red Hat Bugzilla Rules Engine 2015-11-18 07:32:32 EST
This bug is not marked for z-stream, yet the milestone is for a z-stream version, therefore the milestone has been reset.
Please set the correct milestone or add the z-stream flag.
Comment 13 Doron Fediuck 2015-11-26 04:47:09 EST
Let's focus on a single issue. This was already reported as Bug 1274294.

*** This bug has been marked as a duplicate of bug 1274294 ***

Note You need to log in before you can comment on or make changes to this bug.