Bug 1254755 - Cinder LVM iSCSI driver with LIO helper fails to handle multiple concurrent requests to attach/detach volumes
Cinder LVM iSCSI driver with LIO helper fails to handle multiple concurrent r...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
high Severity unspecified
: z5
: 5.0 (RHEL 6)
Assigned To: Gorka Eguileor
Yogev Rabl
: Triaged, ZStream
Depends On: 1221614 1289526
Blocks: 1227404 1227405
  Show dependency treegraph
 
Reported: 2015-08-18 14:56 EDT by Jon Schlueter
Modified: 2016-04-27 01:46 EDT (History)
16 users (show)

See Also:
Fixed In Version: openstack-cinder-2014.1.4-3.el6ost
Doc Type: Bug Fix
Doc Text:
Previous releases did not have synchronized access to configfs in rtslib. This made it possible for rtstool or rtslib to attempt access to an element that had just been removed mid-loop by another Block Storage request (and was, therefore, non-existent). This, in turn, could result in any of the following exceptions: - .dump() - KeyError - IOError - RTSLibError on storage_object This release implements synchronized access to all rtstool calls that access or modify configfs. With this, concurrent access from multiple threads and processes now work consistently.
Story Points: ---
Clone Of: 1221614
Environment:
Last Closed: 2015-09-10 07:47:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1460692 None None None Never
OpenStack gerrit 187260 None None None Never

  None (edit)
Comment 1 Jon Schlueter 2015-08-18 14:58:33 EDT
can we get pm and qa ack on this cloned bug please?
Comment 5 Yogev Rabl 2015-09-09 07:00:54 EDT
verified on openstack-cinder-2014.1.5-1.el6ost.noarch
Comment 7 errata-xmlrpc 2015-09-10 07:47:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1759.html

Note You need to log in before you can comment on or make changes to this bug.