Bug 1289526 - Cinder LVM iSCSI driver with LIO helper fails to handle multiple concurrent requests to attach/detach volumes
Cinder LVM iSCSI driver with LIO helper fails to handle multiple concurrent r...
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
6.0 (Juno)
All Linux
high Severity high
: ---
: 6.0 (Juno)
Assigned To: Eric Harney
nlevinki
: ZStream
Depends On: 1221614
Blocks: 1227404 1227405 1254755
  Show dependency treegraph
 
Reported: 2015-12-08 06:51 EST by Jaison Raju
Modified: 2016-09-08 07:24 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1221614
Environment:
Last Closed: 2015-12-10 08:58:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1400804 None None None Never
Launchpad 1460692 None None None Never
Red Hat Knowledge Base (Solution) 2608671 None None None 2016-09-08 07:24 EDT
OpenStack gerrit 187260 None None None Never

  None (edit)
Comment 1 Jaison Raju 2015-12-09 05:42:04 EST
Hello Team,

Can anyone confirm if the following message is a proof that this bug was triggered ?
May 13 15:56:31 osp1-compute04 kernel: strict_strtoul() failed for port_str: -22

This error has been noticed multiple times in the past but issue where 'nova-compute cannot login to iscsi'  occurred only once .

I was able to recover this by adding acl in target :
# targetcli
/> ls
/> cd /iscsi/iqn.2010-10.org.openstack:volume-3f344318-c12e-4d92-a87c-02c025e6915a/tpg1/acls/iqn.1994-05.com.redhat:95c3136ac590/
/iscsi/iqn.20...:95c3136ac590> get auth

There was no acl set.
I created acl & since no userid & password was set ,so i set it .
Check from /var/lib/iscsi/node/*/* file if node.session.auth variables on compute.
Use same information to set on targetcli .
https://wiki.archlinux.org/index.php/ISCSI_Target

Regards,
Jaison R
Comment 2 Gorka Eguileor 2015-12-10 08:58:11 EST
Please update to latest version as that should be fixed with persistence and concurrency issues patches.

Note You need to log in before you can comment on or make changes to this bug.