Bug 1254865 - non-default symver macros are incorrect
non-default symver macros are incorrect
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
Sudhir D
: Triaged
: 1257405 (view as bug list)
Depends On: 1254863 1257405
Blocks: glusterfs-3.7.4
  Show dependency treegraph
 
Reported: 2015-08-19 02:45 EDT by Kaleb KEITHLEY
Modified: 2015-12-01 11:45 EST (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1254863
Environment:
Last Closed: 2015-09-09 05:40:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-08-19 02:45:56 EDT
+++ This bug was initially created as a clone of Bug #1254863 +++

Description of problem:

Default symbol version macros create versioned symbols in the form glfs_h_lookupat@@3.8.0. The old, non-default version of the symbol should be glfs_h_lookupat@3.4.2.  I.e. "@@" versus "@".

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Anand Avati on 2015-08-19 02:45:30 EDT ---

REVIEW: http://review.gluster.org/11955 (libgfapi: non-default symbol version macros are incorrect) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 1 Anand Avati 2015-08-19 02:55:38 EDT
REVIEW: http://review.gluster.org/11956 (libgfapi: non-default symbol version macros are incorrect) posted (#1) for review on release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com)
Comment 2 Anand Avati 2015-08-20 01:01:37 EDT
COMMIT: http://review.gluster.org/11956 committed in release-3.7 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 591d694a713361d2a6a7b59442730e313fb0b7b6
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Wed Aug 19 02:50:25 2015 -0400

    libgfapi: non-default symbol version macros are incorrect
    
    default symbol versions are in form glfs_h_lookupat@@GFAPI_2.7.4,
    versus old, non-default versions are in the form glfs_h_lookup@GFAPI_2.4.2
    
    I.e. "@@" versus "@"
    
    Backport of:
    * Change-Id: I88a6b129558c0b3a6064de7620b3b20425e80bc9
    * BUG: 1254863
    * http://review.gluster.org/#/c/11955/
    
    Change-Id: I0d53140e03dc2f501ce11d5b2d67373360f2b8b2
    BUG: 1254865
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: http://review.gluster.org/11956
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Soumya Koduri 2015-08-26 23:14:41 EDT
*** Bug 1257405 has been marked as a duplicate of this bug. ***
Comment 4 Kaushal 2015-09-09 05:40:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.