Bug 1254948 - Incorrect evaluation of NOT IN and BETWEEN when types mismatch
Incorrect evaluation of NOT IN and BETWEEN when types mismatch
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
3.2
Unspecified Unspecified
medium Severity medium
: 3.2
: ---
Assigned To: Andrew Stitcher
Michal Toth
:
Depends On:
Blocks: 1258971
  Show dependency treegraph
 
Reported: 2015-08-19 05:57 EDT by Robbie Gemmell
Modified: 2015-10-08 09:11 EDT (History)
7 users (show)

See Also:
Fixed In Version: qpid-cpp-0.34-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1258971 (view as bug list)
Environment:
Last Closed: 2015-10-08 09:11:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-6717 None None None Never

  None (edit)
Description Robbie Gemmell 2015-08-19 05:57:30 EDT
In addition to the header naming issues covered by BZ1254944 there appear to be some further selector related issues, with failures in various tests checking handling of things such as IN/LIKE/BETWEEN/whitespace etc.
Comment 1 Gordon Sim 2015-08-28 18:20:54 EDT
I've identified the issues as (a) incorrect evaluation of NOT IN and BETWEEN when types mismatch and (b) incorrect parsing of certain integer literals.  More details in QPID-6717 and QPID-6718, now linked to this. I have checked in a fix for the first class (https://svn.apache.org/r1698428), the second class are still unresolved.
Comment 2 Irina Boverman 2015-09-01 09:56:34 EDT
Backported (https://svn.apache.org/r1698428) to 0.34-mrg.
Comment 4 Andrew Stitcher 2015-09-04 14:12:38 EDT
[Bug has been split so removing the numeric parsing part]

Now committed fixes to finish this issue to qpid upstream trunk:
(note that one of these changes reverts a previous change)

git mirror SHAs:
27472cd3
420c2a41 (this reverts 85ed093b)
5a416927
c7500cc5

svn urls:
https://svn.apache.org/r1700867
https://svn.apache.org/r1700868 reverting https://svn.apache.org/r1698428
https://svn.apache.org/r1700869
https://svn.apache.org/r1701301
Comment 7 Michal Toth 2015-09-21 03:50:14 EDT
We have ran TCK tests on rhel7, 32 and 64b rhel6 and no selector tests are failing.
Runs were executed on 
qpid-cpp-server-0.34-4.el6.x86_64

Marking as verified.
Comment 9 errata-xmlrpc 2015-10-08 09:11:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1879.html

Note You need to log in before you can comment on or make changes to this bug.