Bug 1258971 - qpidd selector issues when parsing of certain integer literals
qpidd selector issues when parsing of certain integer literals
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
3.1
Unspecified Unspecified
medium Severity medium
: 3.2
: ---
Assigned To: Andrew Stitcher
Otavio Piske
:
Depends On: 1254948
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-01 11:47 EDT by Irina Boverman
Modified: 2015-10-08 09:11 EDT (History)
9 users (show)

See Also:
Fixed In Version: qpid-cpp-0.34-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1254948
Environment:
Last Closed: 2015-10-08 09:11:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-6718 None None None Never

  None (edit)
Description Irina Boverman 2015-09-01 11:47:56 EDT
+++ This bug was initially created as a clone of Bug #1254948 +++

In addition to the header naming issues covered by BZ1254944 there appear to be some further selector related issues, with failures in various tests checking handling of things such as IN/LIKE/BETWEEN/whitespace etc.

--- Additional comment from Gordon Sim on 2015-08-28 18:20:54 EDT ---

I've identified the issues as (a) incorrect evaluation of NOT IN and BETWEEN when types mismatch and (b) incorrect parsing of certain integer literals.  More details in QPID-6717 and QPID-6718, now linked to this. I have checked in a fix for the first class (https://svn.apache.org/r1698428), the second class are still unresolved.

--- Additional comment from Irina Boverman on 2015-09-01 09:56:34 EDT ---

Backported (https://svn.apache.org/r1698428) to 0.34-mrg.
Comment 1 Andrew Stitcher 2015-09-04 14:00:26 EDT
This is now fixed on the upstream qpid trunk:

git mirror SHAs: 492f7a78 & 215baaf0

svn revs:
https://svn.apache.org/repos/asf/qpid/trunk@1700915
https://svn.apache.org/repos/asf/qpid/trunk@1701130
Comment 9 Otavio Piske 2015-10-01 08:53:50 EDT
I had to create a few custom clients to test this, so it took me a little while. The fix is verified and working.
Comment 11 errata-xmlrpc 2015-10-08 09:11:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-1879.html

Note You need to log in before you can comment on or make changes to this bug.