Bug 1255112 - [RFE][Neutron] Backport add onlink route when multiple external subnets
[RFE][Neutron] Backport add onlink route when multiple external subnets
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: z5
: 5.0 (RHEL 6)
Assigned To: lpeer
Itzik Brown
: FutureFeature, Triaged, ZStream
Depends On: 1185200
Blocks: 1188003
  Show dependency treegraph
 
Reported: 2015-08-19 12:37 EDT by Jon Schlueter
Modified: 2016-09-15 07:43 EDT (History)
14 users (show)

See Also:
Fixed In Version: openstack-neutron-2014.1.4-3.el6ost
Doc Type: Enhancement
Doc Text:
Previously, when using multiple subnets on an external network, traffic from one subnet to the other would be forwarded through the upstream router first. This resulted in massive inefficiency, to the point that adoption of the concept of multiple subnets on an external network was hindered. This update addresses this issue by adding an on-link route to each subnet. As a result, a router connected to an external network is attached to one subnet, thus having one IP address (even if that network has multiple subnets). With this fix, the router will still consume an IP address from only subnet, but also has an on-link route to all subnets on the network.
Story Points: ---
Clone Of: 1185200
Environment:
Last Closed: 2015-09-10 07:51:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1312467 None None None Never
OpenStack gerrit 150033 None None None Never

  None (edit)
Comment 3 Itzik Brown 2015-09-01 05:35:07 EDT
Verified in https://bugzilla.redhat.com/show_bug.cgi?id=1185200 using RHEL7.
Comment 5 errata-xmlrpc 2015-09-10 07:51:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1755.html

Note You need to log in before you can comment on or make changes to this bug.