Bug 125519 - etags is installed as "etags.emacs"
etags is installed as "etags.emacs"
Status: CLOSED DUPLICATE of bug 92256
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-08 10:33 EDT by Sam Steingold
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sam Steingold 2004-06-08 10:33:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6)
Gecko/20040206 Firefox/0.8

Description of problem:
Emacs uses its own "Emacs TAGS" tags format (as opposed to "VI tags")
These TAGS files are generated by "etags" program which comes with Emacs.
This program is incorrectly installed as "/usr/bin/etags.emacs"
instead or "/usr/bin/etags". 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install emacs
2.run etags

    

Actual Results:  no such program

Expected Results:  Emacs TAGS file is generated

Additional info:

Apparently you are confused by the fact that Emacs also offers an
implementation of the standard "VI tags" in file ctags (which you
install as "/usr/bin/ctags.emacs" because anther package already
provides a ctags executable.
You have to install "etags" as "/usr/bin/etags".
Comment 1 Jens Petersen 2004-06-21 21:14:09 EDT
No, the problem is that both Emacs and XEmacs provide etags.
Currently the emacs-common %post script is supposed to create
a symlink etags -> etags.emacs if etags doesn't exist.

This works with emacs-common is installed at least - not sure
how well it works with upgrading the first time because rpm
removes the old files *after* the new package is installed
which I believe is after %post is run.  So the first time
emacs-common gets upgraded the symlink will probably not be created
unfortunately.  It should happen the next time emacs-common
is upgraded or of course you can create it yourself.

The right way to do this is to use alternatives, hopefully
that will happen for FC3.

*** This bug has been marked as a duplicate of 92256 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.