Bug 92256 - /usr/bin/etags should be linked to /etc/alternatives
/usr/bin/etags should be linked to /etc/alternatives
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
:
: 125519 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-04 03:57 EDT by Marc MERLIN
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-13 10:50:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc MERLIN 2003-06-04 03:57:18 EDT
etags from emacs is apparently inferior to ctags from vim, except that many
systems (including the ones my engineers used to work on) have etags pointing
to vim's ctags.

Right now, I need to repoint /usr/bin/etags to vim's ctags.
I'm going to do mv etags etags.emacs, ln -s ctags etags

This is all nice and great, except that the next emacs upgrade is going to blow
my symlink away.
Of course, rpm should account for something like this, like I would do on 
debian with dpkg-divert etags etags.divert, but in the meantime, we can at
least repackage emacs and vim so that /usr/bin/etags is a symlink to
/etc/alternatives, like it is on debian.

gandalf:~$ l /usr/bin/etags 
lrwxrwxrwx    1 root     root           23 Aug 13  2002 /usr/bin/etags ->
/etc/alternatives/etags*
gandalf:~$ l /etc/alternatives/etags
lrwxrwxrwx    1 root     root           24 Aug 13  2002 /etc/alternatives/etags
-> /usr/bin/ctags-exuberant*
Comment 1 Jens Petersen 2004-01-13 02:50:34 EST
In emacs-21.3-8 etags will be a symlink to etags.emacs
created at install time if etags doesn't exist.
Comment 2 Jens Petersen 2004-04-15 10:58:04 EDT
Is that good enough for you?
Comment 3 Marc MERLIN 2004-04-15 11:19:20 EDT
Sorry, never saw the January update.

Well, it's better than now, but that's not the proper use of alternatives.
Both vim and emacs should install etags.package, and etags should
point to alternatives, which should then point to the emacs or vim one.

But not blowing the etags symlink away if there is one is already a
good step
Comment 4 Jens Petersen 2004-04-15 23:55:34 EDT
Btw you're talking about the ctags package not vim, right?

Have you opened a similar bug against ctags already to help make
this happen? :)
Comment 5 Marc MERLIN 2004-04-16 12:54:09 EDT
Sure, it's n+1 :)
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=92257

And yes, I got confused, we're talking about ctags, not vim
Comment 6 Jens Petersen 2004-06-21 21:14:12 EDT
*** Bug 125519 has been marked as a duplicate of this bug. ***
Comment 7 Jens Petersen 2004-08-04 23:12:56 EDT
I'm still confused this issue is about the ctags in Emacs
(and XEmacs) vs the one provided by ctags, and not etags, right?
Comment 8 Sam Steingold 2004-08-05 09:16:25 EDT
etags and ctags are completely different, separate programs.
ctags creates file "tags" usable with VI & derivatives.
etags creates file "TAGS" usable with Emacs & derivatives.
for some unfathomable reason, Emacs _also_ distributes ctags, 
while the ctags package apparently comes with etags too.
the "priority list" should be like this:
etags: whatever comes with Emacs, if no Emacs is installed, 
       use whatever comes with ctags
ctags: whatever comes with ctags (or vim?), if not present, 
       use whatever comes with Emacs (or Xemacs).
Just make sure that etags does _not_ point to ctags and vv.
Comment 9 Jens Petersen 2004-09-29 03:54:42 EDT
etags should be handled by alternatives in 21.3-15.

Note You need to log in before you can comment on or make changes to this bug.