Bug 1255193 - blivet.errors.DeviceError: ('cannot replace active format', 'fedora-root')
blivet.errors.DeviceError: ('cannot replace active format', 'fedora-root')
Status: CLOSED DUPLICATE of bug 1255969
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:37a26951cbba423c77d289aef46...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-19 18:32 EDT by Devon Smith
Modified: 2015-08-24 03:08 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-24 03:08:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (669.40 KB, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: anaconda.log (20.04 KB, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: environ (654 bytes, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: journalctl (331.58 KB, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: lsblk_output (2.68 KB, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: nmcli_dev_list (1.26 KB, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: os_info (451 bytes, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: program.log (118.70 KB, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: storage.log (256.08 KB, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details
File: ifcfg.log (2.62 KB, text/plain)
2015-08-19 18:32 EDT, Devon Smith
no flags Details

  None (edit)
Description Devon Smith 2015-08-19 18:32:35 EDT
Version-Release number of selected component:
anaconda-core-23.20-1.fc24.x86_64

The following was filed automatically by anaconda:
anaconda 23.20-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 697, in _setFormat
    raise errors.DeviceError("cannot replace active format", self.name)
  File "/usr/lib/python3.4/site-packages/blivet/devices/lvm.py", line 646, in _setFormat
    super(LVMLogicalVolumeDevice, self)._setFormat(fmt)
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 742, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/python3.4/site-packages/blivet/deviceaction.py", line 669, in apply
    self.device.format = None
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 323, in registerAction
    action.apply()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 275, in recursiveRemove
    self.registerAction(ActionDestroyFormat(leaf))
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 611, in recursiveRemove
    self.devicetree.recursiveRemove(device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 422, in _recursiveRemove
    self.storage.recursiveRemove(device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 447, in _scheduleActions
    self._recursiveRemove(device)
blivet.errors.DeviceError: ('cannot replace active format', 'fedora-root')

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Cinnamon-x86_64-rawh ro rd.live.image quiet rhgb rd.live.check
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc7.git1.1.fc24.x86_64
other involved packages: anaconda-gui-23.20-1.fc24.x86_64, python3-blivet-1.12-1.fc24.noarch
product:        Fedora
release:        Fedora release 24 (Rawhide)
type:           anaconda
version:        Rawhide
Comment 1 Devon Smith 2015-08-19 18:32:37 EDT
Created attachment 1065021 [details]
File: anaconda-tb
Comment 2 Devon Smith 2015-08-19 18:32:38 EDT
Created attachment 1065022 [details]
File: anaconda.log
Comment 3 Devon Smith 2015-08-19 18:32:39 EDT
Created attachment 1065023 [details]
File: environ
Comment 4 Devon Smith 2015-08-19 18:32:40 EDT
Created attachment 1065024 [details]
File: journalctl
Comment 5 Devon Smith 2015-08-19 18:32:41 EDT
Created attachment 1065025 [details]
File: lsblk_output
Comment 6 Devon Smith 2015-08-19 18:32:42 EDT
Created attachment 1065026 [details]
File: nmcli_dev_list
Comment 7 Devon Smith 2015-08-19 18:32:43 EDT
Created attachment 1065027 [details]
File: os_info
Comment 8 Devon Smith 2015-08-19 18:32:44 EDT
Created attachment 1065028 [details]
File: program.log
Comment 9 Devon Smith 2015-08-19 18:32:45 EDT
Created attachment 1065029 [details]
File: storage.log
Comment 10 Devon Smith 2015-08-19 18:32:46 EDT
Created attachment 1065030 [details]
File: ifcfg.log
Comment 11 Vratislav Podzimek 2015-08-24 03:08:24 EDT
This is a duplicate of bug #1255969 which has more information.

*** This bug has been marked as a duplicate of bug 1255969 ***

Note You need to log in before you can comment on or make changes to this bug.