Bug 1255969 - blivet.errors.DeviceError: ('cannot replace active format', 'VolGroup-lv_root')
blivet.errors.DeviceError: ('cannot replace active format', 'VolGroup-lv_root')
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:37a26951cbba423c77d289aef46...
:
: 1255193 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-22 10:58 EDT by Adam Williamson
Modified: 2015-08-26 14:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-26 14:31:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (625.36 KB, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: anaconda.log (19.82 KB, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: environ (573 bytes, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: journalctl (297.04 KB, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: lsblk_output (2.36 KB, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: nmcli_dev_list (2.23 KB, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: os_info (518 bytes, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: program.log (139.07 KB, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: storage.log (227.41 KB, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details
File: ifcfg.log (4.04 KB, text/plain)
2015-08-22 10:58 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2015-08-22 10:58:00 EDT
Description of problem:
Booted the 2015-08-19 Workstation F23 nightly, installed anaconda 23.19 / blivet 1.12.1 update, started the install, went to INSTALLATION DESTINATION and chose to delete all existing partitions (on the guided path). Crashed on return to hub.

Version-Release number of selected component:
anaconda-core-23.19-1.fc23.x86_64

The following was filed automatically by anaconda:
anaconda 23.19-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 697, in _setFormat
    raise errors.DeviceError("cannot replace active format", self.name)
  File "/usr/lib/python3.4/site-packages/blivet/devices/lvm.py", line 646, in _setFormat
    super(LVMLogicalVolumeDevice, self)._setFormat(fmt)
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 742, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/python3.4/site-packages/blivet/deviceaction.py", line 669, in apply
    self.device.format = None
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 323, in registerAction
    action.apply()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 275, in recursiveRemove
    self.registerAction(ActionDestroyFormat(leaf))
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 611, in recursiveRemove
    self.devicetree.recursiveRemove(device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 422, in _recursiveRemove
    self.storage.recursiveRemove(device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 447, in _scheduleActions
    self._recursiveRemove(device)
blivet.errors.DeviceError: ('cannot replace active format', 'VolGroup-lv_root')

Additional info:
cmdline:        /usr/bin/python3  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz0 initrd=initrd0.img root=live:CDLABEL=Fedora-Live-WS-x86_64-23-2015081 rootfstype=auto ro rd.live.image quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-0.rc5.git0.2.fc23.x86_64
other involved packages: anaconda-gui-23.19-1.fc23.x86_64, python3-blivet-1.12-1.fc23.noarch
product:        Fedora
release:        Fedora release 23 (Twenty Three)
type:           anaconda
version:        23

Potential duplicate: bug 1255193
Comment 1 Adam Williamson 2015-08-22 10:58:04 EDT
Created attachment 1065831 [details]
File: anaconda-tb
Comment 2 Adam Williamson 2015-08-22 10:58:05 EDT
Created attachment 1065832 [details]
File: anaconda.log
Comment 3 Adam Williamson 2015-08-22 10:58:06 EDT
Created attachment 1065833 [details]
File: environ
Comment 4 Adam Williamson 2015-08-22 10:58:07 EDT
Created attachment 1065834 [details]
File: journalctl
Comment 5 Adam Williamson 2015-08-22 10:58:08 EDT
Created attachment 1065835 [details]
File: lsblk_output
Comment 6 Adam Williamson 2015-08-22 10:58:09 EDT
Created attachment 1065836 [details]
File: nmcli_dev_list
Comment 7 Adam Williamson 2015-08-22 10:58:10 EDT
Created attachment 1065837 [details]
File: os_info
Comment 8 Adam Williamson 2015-08-22 10:58:12 EDT
Created attachment 1065838 [details]
File: program.log
Comment 9 Adam Williamson 2015-08-22 10:58:13 EDT
Created attachment 1065839 [details]
File: storage.log
Comment 10 Adam Williamson 2015-08-22 10:58:14 EDT
Created attachment 1065840 [details]
File: ifcfg.log
Comment 11 Vratislav Podzimek 2015-08-24 03:08:24 EDT
*** Bug 1255193 has been marked as a duplicate of this bug. ***
Comment 12 Vratislav Podzimek 2015-08-24 04:28:05 EDT
I'm sorry, but I cannot reproduce the issue. I have a VM with an existing F23 installation - autopart, single disk, two partitions (/boot and an LVM PV). With F23 Alpha RC2 I do:

# dnf -y update anaconda python3-blivet && liveinst

and everything works as expected. Adam, could you please test this again and maybe provide some more information about the reproducer? Thanks!
Comment 13 Adam Williamson 2015-08-26 14:31:09 EDT
Hmm, indeed tried again and it didn't happen. I don't recall the precise circumstances of the earlier failure though. Let's close for now and I can reopen if I manage to make it happen again.

Note You need to log in before you can comment on or make changes to this bug.