Bug 1255223 - [Docs] [Beta] [Admin] New live migration features
[Docs] [Beta] [Admin] New live migration features
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Lucy Bopf
Tahlia Richardson
http://www.ovirt.org/Features/XBZRLE_...
docs
:
Depends On: 867453 1109154
Blocks: 1265080
  Show dependency treegraph
 
Reported: 2015-08-19 23:17 EDT by Andrew Dahms
Modified: 2016-02-10 13:56 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 20:40:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
adahms: Triaged+


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2015-08-19 23:17:32 EDT
Users can now enable two new live migration features for virtual machines. While this does not affect users much directly, there is an option to set this using the engine-config command that should be called out in the documentation.

The command is the following -

 engine-config -s (DefaultAutoConvergence|DefaultMigrationCompression)=(true|false) 

A good way to tackle this bug might be to add a short note or two about the two new features to the section on live migration in the Admin Guide and tell users how to run the above to turn this feature on. 

Note: After running the above, users must restart the ovirt-engine service for the change to take effect.
Comment 1 Andrew Dahms 2015-08-24 01:00:35 EDT
Assigning to Lucy for review.
Comment 5 Israel Pinto 2015-11-11 05:03:39 EST
I am missing:
1. Configure form engine CLI:
engine-config -s (DefaultAutoConvergence|DefaultMigrationCompression)=(true|false) 
     
2. VM option in host tab --> Migration Options: 
    Auto Converge migrations
    Enable migration compression

3. The links below don't work:
Links:
http://docbuilder.usersys.redhat.com/23128/#Virtual_Machine_Host_settings_explained
http://docbuilder.usersys.redhat.com/23128/#Optimizing_Live_Migration
Comment 6 Lucy Bopf 2015-11-11 18:56:51 EST
Hi Israel,

After this bug was completed, content related to virtual machines was moved to a new Virtual Machine Management Guide, including those topics you mention above. The updated links are here:

http://docbuilder.usersys.redhat.com/23141/#Virtual_Machine_Host_settings_explained

http://docbuilder.usersys.redhat.com/23141/#Optimizing_Live_Migration


Kind Regards,

Lucy
Comment 7 Tomas Jelinek 2015-11-12 07:54:24 EST
Only one note:

"The VDSM default value is 0." sounds like the default value is 0. Actually if you type 0 it means "use VDSM default". So I would rephrase it to: "0 means to use the VDSM default".
Comment 9 Lucy Bopf 2015-11-23 20:40:35 EST
(In reply to Tomas Jelinek from comment #7)
> Only one note:
> 
> "The VDSM default value is 0." sounds like the default value is 0. Actually
> if you type 0 it means "use VDSM default". So I would rephrase it to: "0
> means to use the VDSM default".

Thank you, Tomas, for the correction and explanation. I've updated that sentence now. The change will appear when the guides are republished. Since the content for this bug has been verified and published, I will now close this bug.

The live migration content is available at the following links:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6-Beta/html-single/Administration_Guide/index.html#Cluster_general_entities
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6-Beta/html-single/Virtual_Machine_Management_Guide/index.html#Virtual_Machine_Host_settings_explained
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6-Beta/html-single/Virtual_Machine_Management_Guide/index.html#Optimizing_Live_Migration

Note You need to log in before you can comment on or make changes to this bug.