Bug 1255224 - [RFE] Add support for Bonding mode 5 and 6 in OSP-Director
[RFE] Add support for Bonding mode 5 and 6 in OSP-Director
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
Director
x86_64 Linux
medium Severity medium
: y3
: 7.0 (Kilo)
Assigned To: Dan Sneddon
Arik Chernetsky
: FutureFeature, ZStream
Depends On:
Blocks: 1258537
  Show dependency treegraph
 
Reported: 2015-08-19 23:26 EDT by Karthik Prabhakar
Modified: 2016-10-30 18:52 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-18 16:55:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1244010 None None None Never
OpenStack gerrit 218134 None None None Never
OpenStack gerrit 219927 None None None Never

  None (edit)
Description Karthik Prabhakar 2015-08-19 23:26:46 EDT
Description of problem:
Requesting adding support for Bonding modes 5 and 6 in OSP-Director deployments. It appears that Bonding modes 2, 3 and 4 are not supported in certain platforms (such as UCS with Fabric Interconnects in end-host mode).

Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.8-44.el7ost.noarch
Comment 3 Dan Sneddon 2015-08-20 11:24:58 EDT
The use case for this is as follows:

Cisco UCS systems have the ability to connect two virtual NICs (vNICs) from different physical ports to a single bare metal node, but they cannot do switch bonding on those two ports.

The ask is that if we could take two ports on the same VLAN and treat them as a bond only from the host side. This would result in load balancing in the transmit direction from the host.

There is a dependency on using Linux bonding (instead of OVS) for this application, since OVS does not support mode 5 or 6 bonds. There would also have to be support for bonding modes 5 & 6 with OSP, which has not been part of our testing matrix to date.

This is untested, but the hypothesis is that because of the way OpenStack uses VM MAC addresses, we expect that mode 6 will not actually result in load balancing of traffic sent to the host. There is still a desire for load balancing for traffic sent from the host.
Comment 4 Dan Sneddon 2015-08-28 13:44:39 EDT
This should be addressed by this upstream patch which will enable Linux bonding instead of OVS bonding:

https://review.openstack.org/#/c/218134/
Comment 5 Dan Sneddon 2015-09-18 10:52:34 EDT
Here is a related patch to enable Linux bridges:

https://review.openstack.org/#/c/219927/
Comment 10 Hugh Brock 2016-02-28 02:31:04 EST
I think this is done for Liberty, isn't it Dan?
Comment 11 Dan Sneddon 2016-02-29 11:28:00 EST
(In reply to Hugh Brock from comment #10)
> I think this is done for Liberty, isn't it Dan?

Yes, it is done for Liberty and was backported to OSP 7 and OSP 8 already.
Comment 12 Mike Burns 2016-04-07 16:47:27 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 13 Dan Sneddon 2016-04-18 16:55:40 EDT
Despite the last comment to the contrary, this bug was fixed in 7.3, and also in the upcoming 8.0. Closing this bug as it is fixed in the current release.

Note You need to log in before you can comment on or make changes to this bug.