Bug 1244010 - RFE: os-net-config should support linux bonds and VLAN interfaces
Summary: RFE: os-net-config should support linux bonds and VLAN interfaces
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-net-config
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: y2
: 7.0 (Kilo)
Assignee: RHOS Maint
QA Contact: Asaf Hirshberg
URL:
Whiteboard:
Keywords: FutureFeature, ZStream
: 1276708 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-16 21:06 UTC by Dan Sneddon
Modified: 2016-04-11 16:58 UTC (History)
20 users (show)

(edit)
This enhancement adds Linux bonding configuration through the director. The director used only OVS and VLAN bonding previously. Linux bonding provides increased performance and additional bonding modes.
Clone Of:
(edit)
Last Closed: 2015-12-21 16:54:04 UTC


Attachments (Terms of Use)
original controller.yaml using ovs bonds (5.63 KB, text/plain)
2016-04-11 16:54 UTC, Dan Sneddon
no flags Details
controller.yaml with linux bonds example (5.62 KB, text/plain)
2016-04-11 16:56 UTC, Dan Sneddon
no flags Details
compute.yaml with linux bonds example (4.86 KB, text/plain)
2016-04-11 16:57 UTC, Dan Sneddon
no flags Details
ceph-storage.yaml with linux bonds example (4.49 KB, text/plain)
2016-04-11 16:58 UTC, Dan Sneddon
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2651 normal SHIPPED_LIVE Red Hat Enterprise Linux OSP 7 director Bug Fix Advisory 2015-12-21 21:50:26 UTC
OpenStack gerrit 218134 None None None Never
OpenStack gerrit 219927 None None None Never
OpenStack gerrit 231247 None None None Never
Red Hat Bugzilla 1275731 None None None Never

Internal Trackers: 1255224

Description Dan Sneddon 2015-07-16 21:06:04 UTC
Description of problem:
os-net-config only supports OVS bonds and VLAN interfaces. This introduces extra complexity (one or more extra bridges), and a packet-processing path that is potentially less performant.

Version-Release number of selected component (if applicable):
OSP 7 GA

How reproducible:
100%

Steps to Reproduce:
1. Deploy OSP 7
2.
3.

Actual results:
All overcloud instances are using OVS for the bonds and VLAN interfaces in addition to the bridges.

Expected results:
We used to use Linux bonds and VLAN interfaces in OSP 5 & 6. A lot of people had an expectation that we would be continuing to use, or at least support, Linux bonds and bridges in OSP 7. The networking in OSP 7 is harder for people to grasp since they are used to Linux bonds and VLAN interfaces.

OVS has a reputation for delivering less performance in bridging than Linux. It is likely that there is at least some performance impact when using OVS for bonds and VLAN interfaces as well.

Additional info:
We don't actually know if there is a performance impact from using OVS bonds and VLAN interfaces, but it's something that we should test. If there is a performance gap, it may be good to switch the default in an async release.

In addition, some advanced networking architectures that use 3rd-party plugins require Linux bridge support. We may have issues integrating with SDN or NFV solutions if we only support OVS bonds and VLANs (speculation, actual impact unknown).

Linux bonds support additional modes for bonding, so there may be a preference to use Linux bonds.

Comment 3 chris alfonso 2015-08-05 18:03:42 UTC
Nir, can you provide some feedback on whether this is something the field is going to need implemented, and an idea of how important it is that we get this working?

Comment 10 Salman Khan 2015-11-11 13:14:16 UTC
Is this going to be supported in 8.0 Director or we could expect in 7.0 as well.

Comment 11 Dan Sneddon 2015-11-11 17:16:10 UTC
(In reply to Salman Khan from comment #10)
> Is this going to be supported in 8.0 Director or we could expect in 7.0 as
> well.

These features will be in the final point release of OSP 7/OSP-Director 7.2. The change is in beta testing now.

Comment 12 chris alfonso 2015-11-11 17:43:51 UTC
*** Bug 1276708 has been marked as a duplicate of this bug. ***

Comment 13 Randy Perryman 2015-12-08 20:22:10 UTC
Couple of questions: 
1. does this affect non - OVS bonding, i.e. kernel?
2. How does this affect ha-proxy and pacemaker?

Comment 21 errata-xmlrpc 2015-12-21 16:54:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2651

Comment 22 Dan Sneddon 2016-04-11 16:54 UTC
Created attachment 1146051 [details]
original controller.yaml using ovs bonds

Comment 23 Dan Sneddon 2016-04-11 16:56 UTC
Created attachment 1146052 [details]
controller.yaml with linux bonds example

Comment 24 Dan Sneddon 2016-04-11 16:57 UTC
Created attachment 1146053 [details]
compute.yaml with linux bonds example

Comment 25 Dan Sneddon 2016-04-11 16:58 UTC
Created attachment 1146054 [details]
ceph-storage.yaml with linux bonds example

Comment 26 Dan Sneddon 2016-04-11 16:58:51 UTC
Added examples of linux bond templates


Note You need to log in before you can comment on or make changes to this bug.