Bug 1255266 - [ja_JP] [Admin Portal] Text truncation observed on clusters->general tab
[ja_JP] [Admin Portal] Text truncation observed on clusters->general tab
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
All Linux
medium Severity medium
: ovirt-3.6.1
: 3.6.1
Assigned To: Alexander Wels
Pavel Stehlik
: i18n
Depends On: 1205309
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 03:13 EDT by Bhushan Barve
Modified: 2016-04-19 21:25 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:25:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Emulated Machine truncation in ja_JP (83.56 KB, image/png)
2015-08-20 03:14 EDT, Bhushan Barve
no flags Details
Cluster Emulated Machine - Japanese - properly wrapping. (128.96 KB, image/png)
2015-12-01 14:54 EST, Einav Cohen
no flags Details

  None (edit)
Description Bhushan Barve 2015-08-20 03:13:29 EDT
Description of problem: There is some text truncation observed on clusters->general tab for ja_JP locale. The field name 'エミュレーションする仮想マシンタイプ:' (Emulated Machine:) gets truncated. Please refer attached screenshot for the same.


Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager バージョン: 3.6.0-0.11.master.el6

How reproducible:
always

Steps to Reproduce:
1. login to admin portal with ja_JP locale
2. got to clusters->general tab
3. observe the field name 'エミュレーションする仮想マシンタイプ:' (i.e Emulated Machine)

Actual results:
The field name gets truncated and appears partially cut.

Expected results:
There should not be any truncation

Additional info:
Comment 1 Bhushan Barve 2015-08-20 03:14:38 EDT
Created attachment 1065127 [details]
Emulated Machine truncation in ja_JP
Comment 2 Einav Cohen 2015-08-21 15:55:51 EDT
just like for grid column headers, general sub-tab information will inevitably be truncated for some locales; what we need is to have the full value visible in a tool-tip upon hovering on the truncated value - this is tracked via bug 1205309.
Comment 3 Einav Cohen 2015-12-01 14:54 EST
Created attachment 1100997 [details]
Cluster Emulated Machine - Japanese - properly wrapping.
Comment 4 Einav Cohen 2015-12-01 14:54:55 EST
looks like this was already fixed in rhevm-3.6.0-22. moving to ON_QA.
Comment 5 Einav Cohen 2015-12-01 14:58:03 EST
QA: please note that per bug 1149630, this issue was fixed globally by wrapping long labels to be rendered across multiple lines (see attachment 1100997 [details]).
Comment 6 Bhushan Barve 2015-12-07 07:26:30 EST
Tested with Red Hat Enterprise Virtualization Manager バージョン: 3.6.1.1-0.1.el6 

Now the truncation is no more observed for the field name 'エミュレーションする仮想マシンタイプ:' (i.e Emulated Machine). 
Marking it as verified.
Comment 7 Alexander Wels 2016-01-19 10:36:40 EST
Yaniv or Moran, can I get a PM ack on this?

Note You need to log in before you can comment on or make changes to this bug.