Bug 1255310 - Snapshot: When soft limit is reached, auto-delete is enable, create snapshot doesn't logs anything in log files
Snapshot: When soft limit is reached, auto-delete is enable, create snapshot ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Avra Sengupta
: Reopened, Triaged, ZStream
Depends On: 1231080
Blocks: 1223636 1255311
  Show dependency treegraph
 
Reported: 2015-08-20 05:12 EDT by Avra Sengupta
Modified: 2016-06-16 09:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1231080
: 1255311 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:33:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-20 05:23:46 EDT
REVIEW: http://review.gluster.org/11963 (snapshot: Log deletion of snapshot, during auto-delete) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2015-08-24 02:48:47 EDT
COMMIT: http://review.gluster.org/11963 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 69942154e197d753580b74cc7f8e6bce470ee673
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu Aug 20 14:40:29 2015 +0530

    snapshot: Log deletion of snapshot, during auto-delete
    
    When auto-delete is enabled, and soft-limit is reached,
    on creation of a snapshot, the oldest snapshot for that
    volume is deleted.
    
    Displaying a warning log before deleting the oldest
    snapshot.
    
    Change-Id: I75f0366935966a223b63a4ec5ac13f9fe36c0e82
    BUG: 1255310
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11963
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Nagaprasad Sathyanarayana 2015-10-25 10:50:42 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 4 Niels de Vos 2016-06-16 09:33:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.