Bug 1255311 - Snapshot: When soft limit is reached, auto-delete is enable, create snapshot doesn't logs anything in log files
Snapshot: When soft limit is reached, auto-delete is enable, create snapshot ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.3
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Avra Sengupta
: Triaged, ZStream
Depends On: 1231080 1255310
Blocks: 1223636
  Show dependency treegraph
 
Reported: 2015-08-20 05:14 EDT by Avra Sengupta
Modified: 2015-10-01 07:04 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1255310
Environment:
Last Closed: 2015-09-09 05:40:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2015-08-20 05:26:33 EDT
REVIEW: http://review.gluster.org/11964 (snapshot: Log deletion of snapshot, during auto-delete) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2015-08-24 02:51:29 EDT
COMMIT: http://review.gluster.org/11964 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 38f0caa2179f2594b9e49f7b06d246693db92c44
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Thu Aug 20 14:40:29 2015 +0530

    snapshot: Log deletion of snapshot, during auto-delete
    
        Backport of http://review.gluster.org/#/c/11963/
    
    When auto-delete is enabled, and soft-limit is reached,
    on creation of a snapshot, the oldest snapshot for that
    volume is deleted.
    
    Displaying a warning log before deleting the oldest
    snapshot.
    
    Change-Id: I75f0366935966a223b63a4ec5ac13f9fe36c0e82
    BUG: 1255311
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/11964
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 3 Kaushal 2015-09-09 05:40:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.