Bug 1255316 - tc does not allow to attach pfifo_fast qdisc
Summary: tc does not allow to attach pfifo_fast qdisc
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Phil Sutter
QA Contact: Jaroslav Aster
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-20 09:36 UTC by Phil Sutter
Modified: 2015-11-19 14:43 UTC (History)
0 users

Fixed In Version: iproute-3.10.0-52.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1261115 (view as bug list)
Environment:
Last Closed: 2015-11-19 14:43:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2117 normal SHIPPED_LIVE iproute bug fix and enhancement update 2015-11-19 11:35:06 UTC

Description Phil Sutter 2015-08-20 09:36:06 UTC
'tc' program of current RHEL7's iproute package does not allow to attach pfifo_fast qdisc to a device:

# tc qd show dev eth0
qdisc pfifo_fast 0: root refcnt 2 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
# tc qd replace dev eth0 root pfifo
# tc qd show dev eth0
qdisc pfifo 8004: root refcnt 2 limit 1000p
# tc qd replace dev eth0 root pfifo_fast
qdisc 'pfifo_fast' does not support option parsing

This is an obvious bug (no options were given above, still tc complains). It has been fixed upstream:

commit e9e78b0db0e023035e346ba67de838be851eb665
Author: Stephen Hemminger <stephen@networkplumber.org>
Date:   Mon Aug 26 08:41:19 2013 -0700

    tc: allow qdisc without options
    
    Pfifo_fast needs no options. So don't force it to have parsing code.

commit 0a502b21e30be835dcad8d9c6023a41da8709eb1
Author: Stephen Hemminger <stephen@networkplumber.org>
Date:   Sun Oct 27 12:26:47 2013 -0700

    Fix handling of qdis without options
    
    Some qdisc like htb want the parse_qopt to be called even if no options
    present. Fixes regression caused by:
    
    e9e78b0db0e023035e346ba67de838be851eb665 is the first bad commit
    commit e9e78b0db0e023035e346ba67de838be851eb665
    Author: Stephen Hemminger <stephen@networkplumber.org>
    Date:   Mon Aug 26 08:41:19 2013 -0700
    
        tc: allow qdisc without options

Comment 4 errata-xmlrpc 2015-11-19 14:43:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2117.html


Note You need to log in before you can comment on or make changes to this bug.