Bug 1261115 - tc does not allow to attach pfifo_fast qdisc
tc does not allow to attach pfifo_fast qdisc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: iproute (Show other bugs)
6.8
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Phil Sutter
Jaroslav Aster
:
Depends On: 1288472
Blocks: 1172231 1275424
  Show dependency treegraph
 
Reported: 2015-09-08 11:38 EDT by Jaroslav Aster
Modified: 2016-05-10 20:19 EDT (History)
6 users (show)

See Also:
Fixed In Version: iproute-2.6.32-46.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1255316
Environment:
Last Closed: 2016-05-10 20:19:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Aster 2015-09-08 11:38:49 EDT
The same issue on rhel-6.

# tc qd replace dev eth0 root pfifo

# tc qd replace dev eth0 root pfifo_fast
qdisc 'pfifo_fast' does not support option parsing

# rpm -q iproute
iproute-2.6.32-45.el6.i686

+++ This bug was initially created as a clone of Bug #1255316 +++

'tc' program of current RHEL7's iproute package does not allow to attach pfifo_fast qdisc to a device:

# tc qd show dev eth0
qdisc pfifo_fast 0: root refcnt 2 bands 3 priomap  1 2 2 2 1 2 0 0 1 1 1 1 1 1 1 1
# tc qd replace dev eth0 root pfifo
# tc qd show dev eth0
qdisc pfifo 8004: root refcnt 2 limit 1000p
# tc qd replace dev eth0 root pfifo_fast
qdisc 'pfifo_fast' does not support option parsing

This is an obvious bug (no options were given above, still tc complains). It has been fixed upstream:

commit e9e78b0db0e023035e346ba67de838be851eb665
Author: Stephen Hemminger <stephen@networkplumber.org>
Date:   Mon Aug 26 08:41:19 2013 -0700

    tc: allow qdisc without options
    
    Pfifo_fast needs no options. So don't force it to have parsing code.

commit 0a502b21e30be835dcad8d9c6023a41da8709eb1
Author: Stephen Hemminger <stephen@networkplumber.org>
Date:   Sun Oct 27 12:26:47 2013 -0700

    Fix handling of qdis without options
    
    Some qdisc like htb want the parse_qopt to be called even if no options
    present. Fixes regression caused by:
    
    e9e78b0db0e023035e346ba67de838be851eb665 is the first bad commit
    commit e9e78b0db0e023035e346ba67de838be851eb665
    Author: Stephen Hemminger <stephen@networkplumber.org>
    Date:   Mon Aug 26 08:41:19 2013 -0700
    
        tc: allow qdisc without options
Comment 12 errata-xmlrpc 2016-05-10 20:19:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0895.html

Note You need to log in before you can comment on or make changes to this bug.