Bug 1255323 - [abrt] yumex-dnf: status.py:128:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'
[abrt] yumex-dnf: status.py:128:handle_dbus_signals:AttributeError: 'NoneType...
Status: CLOSED DUPLICATE of bug 1224524
Product: Fedora
Classification: Fedora
Component: yumex-dnf (Show other bugs)
21
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:13769c23ee12a3c2cf95bbe3a85...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 05:41 EDT by Sylvain Arth
Modified: 2015-10-24 12:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 04:35:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (838 bytes, text/plain)
2015-08-20 05:41 EDT, Sylvain Arth
no flags Details
File: environ (1.11 KB, text/plain)
2015-08-20 05:41 EDT, Sylvain Arth
no flags Details

  None (edit)
Description Sylvain Arth 2015-08-20 05:41:37 EDT
Version-Release number of selected component:
yumex-dnf-4.1.2-1.fc21

Additional info:
reporter:       libreport-2.3.0
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf --updateall
executable:     /usr/bin/yumex-dnf
kernel:         4.1.4-100.fc21.i686
runlevel:       N 5
type:           Python3
uid:            500

Truncated backtrace:
status.py:128:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 71, in __call__
    return getattr(self.proxy, self.method)(*args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 120, in _on_g_signal
    self.handle_dbus_signals(proxy, sender, signal, args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 128, in handle_dbus_signals
    self.app.win.on_status_icon_clicked()
AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Local variables in innermost frame:
signal: 'IconClickSignal'
args: ()
proxy: <DBusProxy object at 0xb595acac (GDBusProxy at 0x8724ec0)>
self: <yumex.status.StatusIcon object at 0xb57de14c>
sender: ':1.141'

Potential duplicate: bug 1224554
Comment 1 Sylvain Arth 2015-08-20 05:41:40 EDT
Created attachment 1065201 [details]
File: backtrace
Comment 2 Sylvain Arth 2015-08-20 05:41:41 EDT
Created attachment 1065202 [details]
File: environ
Comment 3 Tim Lauridsen 2015-10-06 04:35:24 EDT

*** This bug has been marked as a duplicate of bug 1224524 ***

Note You need to log in before you can comment on or make changes to this bug.