Bug 1224524 - [abrt] handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'
Summary: [abrt] handle_dbus_signals:AttributeError: 'NoneType' object has no attribute...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex-dnf
Version: 22
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5ce5ae2f9e500d699180d69cfa8...
: 1224554 1224828 1225079 1225223 1229957 1233007 1255323 1263786 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-05-24 01:32 UTC by Pavel Mlčoch
Modified: 2016-06-10 09:47 UTC (History)
9 users (show)

Fixed In Version: yumex-dnf-4.1.4-1.fc22
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 12:24:02 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (845 bytes, text/plain)
2015-05-24 01:32 UTC, Pavel Mlčoch
no flags Details
File: environ (746 bytes, text/plain)
2015-05-24 01:32 UTC, Pavel Mlčoch
no flags Details

Description Pavel Mlčoch 2015-05-24 01:32:24 UTC
Version-Release number of selected component:
yumex-dnf-4.1.1-1.fc22

Additional info:
reporter:       libreport-2.5.1
cmdline:        /usr/bin/python3 -tt /usr/bin/yumex-dnf --updateall
executable:     /usr/bin/yumex-dnf
kernel:         4.0.1-300.fc22.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
status.py:121:handle_dbus_signals:AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 71, in __call__
    return getattr(self.proxy, self.method)(*args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 113, in _on_g_signal
    self.handle_dbus_signals(proxy, sender, signal, args)
  File "/usr/lib/python3.4/site-packages/yumex/status.py", line 121, in handle_dbus_signals
    self.app.win.on_status_icon_clicked()
AttributeError: 'NoneType' object has no attribute 'on_status_icon_clicked'

Local variables in innermost frame:
signal: 'IconClickSignal'
proxy: <DBusProxy object at 0x7f32801a5900 (GDBusProxy at 0x1a37b10)>
self: <yumex.status.StatusIcon object at 0x7f32801a6ba8>
sender: ':1.99'
args: ()

Comment 1 Pavel Mlčoch 2015-05-24 01:32:28 UTC
Created attachment 1029138 [details]
File: backtrace

Comment 2 Pavel Mlčoch 2015-05-24 01:32:29 UTC
Created attachment 1029139 [details]
File: environ

Comment 3 Tim Lauridsen 2015-05-25 07:02:23 UTC
This is fixed upstream

Comment 4 Tim Lauridsen 2015-05-25 07:03:03 UTC
*** Bug 1224554 has been marked as a duplicate of this bug. ***

Comment 5 Tim Lauridsen 2015-05-27 04:57:32 UTC
*** Bug 1225223 has been marked as a duplicate of this bug. ***

Comment 6 Tim Lauridsen 2015-05-27 04:59:00 UTC
*** Bug 1224828 has been marked as a duplicate of this bug. ***

Comment 7 Tim Lauridsen 2015-05-27 04:59:41 UTC
*** Bug 1225079 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2015-05-27 16:26:27 UTC
dnfdaemon-0.3.9-1.fc22,yumex-dnf-4.1.3-1.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/dnfdaemon-0.3.9-1.fc22,yumex-dnf-4.1.3-1.fc22

Comment 9 Fedora Update System 2015-05-27 16:26:38 UTC
dnfdaemon-0.3.9-1.fc21,yumex-dnf-4.1.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dnfdaemon-0.3.9-1.fc21,yumex-dnf-4.1.3-1.fc21

Comment 10 Fedora Update System 2015-05-28 12:01:38 UTC
Package dnfdaemon-0.3.9-1.fc21, yumex-dnf-4.1.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnfdaemon-0.3.9-1.fc21 yumex-dnf-4.1.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-9000/dnfdaemon-0.3.9-1.fc21,yumex-dnf-4.1.3-1.fc21
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2015-10-01 07:35:38 UTC
dnfdaemon-0.3.10-1.fc22 yumex-dnf-4.1.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-816c17411d

Comment 12 Fedora Update System 2015-10-04 01:37:21 UTC
dnfdaemon-0.3.10-1.fc22, yumex-dnf-4.1.4-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update yumex-dnf dnfdaemon'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-816c17411d

Comment 13 Tim Lauridsen 2015-10-06 08:34:01 UTC
*** Bug 1233007 has been marked as a duplicate of this bug. ***

Comment 14 Tim Lauridsen 2015-10-06 08:34:36 UTC
*** Bug 1263786 has been marked as a duplicate of this bug. ***

Comment 15 Tim Lauridsen 2015-10-06 08:35:24 UTC
*** Bug 1255323 has been marked as a duplicate of this bug. ***

Comment 16 Tim Lauridsen 2015-10-06 08:36:57 UTC
*** Bug 1229957 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2015-11-19 12:23:49 UTC
dnfdaemon-0.3.10-1.fc22, yumex-dnf-4.1.4-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.