Bug 1255324 - [RFE] connection to openstack amqp provider need to be granular
[RFE] connection to openstack amqp provider need to be granular
Status: CLOSED DUPLICATE of bug 1296146
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Greg Blomquist
Dave Johnson
: FutureFeature
Depends On:
  Show dependency treegraph
Reported: 2015-08-20 05:42 EDT by August Simonelli
Modified: 2016-02-19 16:39 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2016-02-19 16:39:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description August Simonelli 2015-08-20 05:42:41 EDT
Description of problem:
When connecting CFME to RHEOSP7 you need to add amqp provider details. The credentials are then used against the IP in the main provider section. The problem is, with rhelosp7, the queue isn't exposed on that IP anymore. Often that IP is an external one, but in rhelosp7 queues use an internal ha mechanism and are not exposed via haproxy or a vip. Because of this you have to add the amqp port to haproxy.

Version-Release number of selected component (if applicable):

How reproducible:
Connecting CFME to rhelosp7 overcloud.

Steps to Reproduce:
1. Deploy director based rhelosp7
2. Create overcloud (cloud) provider connection.
3. Fill our amqp details

Actual results:
amqp port not listening on IP added

Expected results:
amqp is reachable

Additional info:
This is due to a change in rhelosp7 director deployments to not use pacemaker or haproxy for rabbit. It would be great if cfme could be more granular in it's ability to allow you to set a separate ip for the queue (and also a unique port if required -ie if ssl, etc).
Comment 2 Marius Cornea 2015-09-24 10:55:20 EDT
I think we need to address 2 issues regarding the rabbit setup in an OSP7 HA environment and reaching it from CFME:

1. All the 3 OSP controllers run a rabbit instance with mirrored queues. In order for CFME to use all of them in a HA manner the rabbit client needs to know about all the 3 rabbit ip addresses.

2. Rabbit binds on the internal_api network which is usually an isolated network so CFME won't be able to reach it unless it has a direct nic connected to that network.
Comment 3 Greg Blomquist 2016-02-19 16:39:48 EST

*** This bug has been marked as a duplicate of bug 1296146 ***

Note You need to log in before you can comment on or make changes to this bug.