Bug 1296146 - [RFE] specify the AMQP server IP address for Openstack providers
[RFE] specify the AMQP server IP address for Openstack providers
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Julian Cheal
Marius Cornea
openstack
: FutureFeature
: 1103965 1255324 (view as bug list)
Depends On:
Blocks: 1326509
  Show dependency treegraph
 
Reported: 2016-01-06 08:08 EST by Marius Cornea
Modified: 2016-09-08 10:09 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
: 1310114 (view as bug list)
Environment:
Last Closed: 2016-09-08 10:09:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2016-01-06 08:08:18 EST
Description of problem:
We're not able to specify the AMQP server IP address for Openstack providers. When deploying an undercloud with SSL enabled the Keystone endpoints are set on a different IP address than the one RabbitMQ uses to bind. Thus the RabbitMQ server can't be reached from Cloudforms side.
Comment 3 Tzach Shefi 2016-02-04 08:13:09 EST
Also need to support Staypuft installed Openstack, in my case an old Juno HA deployment, Rabbit is running at port 35672. 

I've installed it a while back, don't remember (or think) I had done any custom rabbit port settings. Other than port issue, Rabbit only listens on internal staypuft IP's  (192.168.0.X) this is another problem not related, probably  could be fixed on Staypuft installer's side. 

Tested with CFME 5.5.2.4.20160127105142_395c086
Comment 4 Greg Blomquist 2016-02-18 16:35:39 EST
Julian, this is dependent on the multi-endpoint work you're working on.
Comment 5 Greg Blomquist 2016-02-19 16:39:48 EST
*** Bug 1255324 has been marked as a duplicate of this bug. ***
Comment 6 Greg Blomquist 2016-02-19 17:59:00 EST
*** Bug 1103965 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.