Bug 1255369 - Improve session settings for horizon
Improve session settings for horizon
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
Juno
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Javier Peña
Shai Revivo
:
: 1270213 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 07:49 EDT by Matthias Runge
Modified: 2017-06-18 03:02 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 03:02:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 318775 None None None 2016-05-19 12:51 EDT

  None (edit)
Description Matthias Runge 2015-08-20 07:49:02 EDT
Description of problem:
/etc/openstack-dashboard/local_settings
misses
 
SESSION_ENGINE = 'django.contrib.sessions.backends.cache'

We're currently not setting up a memcache, but not setting to use it as store for sessions

Horizon uses signed cookies by default for session storage. Unfortunately, this has a size limitation of 4k.
Comment 3 Matthias Runge 2015-09-18 15:08:22 EDT
Better option is to set up a database for horizon session data, memcached and to use 
SESSION_ENGINE = "django.contrib.sessions.backends.cached_db"
Comment 4 Alan Pevec 2015-10-30 06:33:10 EDT
*** Bug 1270213 has been marked as a duplicate of this bug. ***
Comment 5 Emilien Macchi 2015-12-02 14:37:41 EST
which installer are you taking about?
puppet-horizon already supports django_session_engine parameter in init.pp - I'm interested to know what change you want in OPM.
Comment 6 Matthias Runge 2015-12-02 15:35:57 EST
The last time (about a week ago) I used packstack, and the setting from comment#3 was not added (or something similar)
Comment 7 Matthias Runge 2015-12-02 15:36:55 EST
Oh, btw. it was rhos-8 that I installed for my local tests here; I don't have the environment to use osp-d.
Comment 9 Javier Peña 2016-05-19 12:51:03 EDT
I have proposed https://review.openstack.org/318775 with a fix. The patch uses memcache as backend and 'django.contrib.sessions.backends.cache' as SESSION_ENGINE, since setting up a database for caching would go beyond the Packstack use case.
Comment 10 Christopher Brown 2017-06-18 03:02:27 EDT
Fixed was merged so closing this.

Note You need to log in before you can comment on or make changes to this bug.