Bug 1270213 - sometimes I can't login into horizon
sometimes I can't login into horizon
Status: CLOSED DUPLICATE of bug 1255369
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Matthias Runge
Ido Ovadia
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-09 05:51 EDT by Martin Pavlásek
Modified: 2015-10-30 06:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-09 08:16:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
horizon.log (1.86 KB, text/plain)
2015-10-09 06:50 EDT, Martin Pavlásek
no flags Details

  None (edit)
Description Martin Pavlásek 2015-10-09 05:51:21 EDT
Description of problem:
Sometimes I couldn't log in into Horizon with no obvious reason or any error message. It's quite confusing situation for end user, if he provide correct credentials and he is redirected to login page. I tried that with two users (demo, admin) and it doesn't work in both cases.

Version-Release number of selected component (if applicable):
python-django-horizon-2015.1.0-11.el7ost.noarch
python-django-1.8.3-1.el7.noarch
python-django-openstack-auth-1.2.0-4.el7ost.noarch
openstack-dashboard-2015.1.0-11.el7ost.noarch
openstack-dashboard-theme-2015.1.0-11.el7ost.noarch

How reproducible:
1/20, quite rarely

Steps to Reproduce:
1. navigate to dashboard (like http://ip/
2. fill login form with valid credentials, click to Sign in button
3.

Actual results:
User is not logged in although user/password combination was correct, also there is any displayed error message.

Expected results:
User should be logged in by first attempt.

Additional info:

WORKAROUND:
Remove "sessionid" cookie (i.e. by FireBug), refresh page and try to log in again - this works in 100%.
Comment 2 Martin Pavlásek 2015-10-09 06:12:35 EDT
Discovered in my local firefox v34 and openstack environment is running on RHEL 7.1
Comment 3 Matthias Runge 2015-10-09 06:31:45 EDT
I assume, you have something in logs, esp about cookie size?
Comment 4 Martin Pavlásek 2015-10-09 06:50 EDT
Created attachment 1081280 [details]
horizon.log

Part of horizon.log that is related to cookie size.
Comment 5 Matthias Runge 2015-10-09 08:16:13 EDT
here you go.

add
SESSION_ENGINE = 'django.contrib.sessions.backends.cache'

to your local settings, make sure, you have a memcached installed and configured
systemctl restart httpd

I opened a bug about this a while ago on installer

https://bugzilla.redhat.com/show_bug.cgi?id=1255369
Comment 6 Alan Pevec 2015-10-30 06:33:10 EDT

*** This bug has been marked as a duplicate of bug 1255369 ***

Note You need to log in before you can comment on or make changes to this bug.