Bug 1255418 - engine-backup - parameters error
engine-backup - parameters error
Status: CLOSED DUPLICATE of bug 1240923
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.6.0
Unspecified Unspecified
low Severity low
: ovirt-4.0.0-alpha
: 4.0.0
Assigned To: Yedidyah Bar David
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 10:13 EDT by Petr Kubica
Modified: 2017-11-05 09:31 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-16 01:41:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Integration
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kubica 2015-08-20 10:13:06 EDT
Description of problem:
When someone tried to run engine-backup without necessary parameters lead to many error in terminal.

[root@pk-rh35 ~]# engine-backup --mode=backup
FATAL: --file is missing
readlink: missing operand
Try `readlink --help' for more information.
/usr/bin/engine-backup: line 1398: : No such file or directory
Notifying engine
/usr/bin/engine-backup: line 1465: : No such file or directory
/usr/bin/engine-backup: line 1398: : No such file or directory
readlink: missing operand
Try `readlink --help' for more information.
/usr/bin/engine-backup: line 1398: : No such file or directory
Notifying engine
/usr/bin/engine-backup: line 1465: : No such file or directory
/usr/bin/engine-backup: line 1398: : No such file or directory
readlink: missing operand
Try `readlink --help' for more information.
/usr/bin/engine-backup: line 1398: : No such file or directory
Notifying engine
/usr/bin/engine-backup: line 1465: : No such file or directory
/usr/bin/engine-backup: line 1398: : No such file or directory
readlink: missing operand
.... (infinity repeated) ....

After specify all necessary parameters everything works

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.11.master.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. Have an engine 
2. command "engine-backup --mode=backup" (without --scope, --file, --log)

Expected results:
Warning about missing necessary parameters
Comment 1 Yedidyah Bar David 2015-11-16 01:41:53 EST

*** This bug has been marked as a duplicate of bug 1240923 ***

Note You need to log in before you can comment on or make changes to this bug.