Bug 1255504 - rhel-osp-director: "openstack baremetal import --json instackenv.json" - need to remove the requirement of disk,memory,cpu, arch
rhel-osp-director: "openstack baremetal import --json instackenv.json" - nee...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: os-cloud-config (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: ---
: 8.0 (Liberty)
Assigned To: Jay Dobies
Alexander Chuzhoy
: Triaged, ZStream
: 1274333 (view as bug list)
Depends On:
Blocks: 1271890
  Show dependency treegraph
 
Reported: 2015-08-20 14:49 EDT by Alexander Chuzhoy
Modified: 2017-11-14 10:37 EST (History)
5 users (show)

See Also:
Fixed In Version: os-cloud-config-0.3.0-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1271890 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:39:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 231613 None None None Never

  None (edit)
Description Alexander Chuzhoy 2015-08-20 14:49:31 EDT
rhel-osp-director: "openstack baremetal import --json instackenv.json" -  need to remove the requirement of having disk,memory,cpu, arch lines.

Currently if one of disk,memory,cpu, arch is missing in the json file - the user gets an error like:
ERROR: openstack 'disk'
ERROR: openstack 'memory'
ERROR: openstack 'cpu'
ERROR: openstack 'arch'

during the run of "openstack baremetal import --json instackenv.json".


The values for these don't have to reflect the environment and are actually changed to what's on the machine(s) during the introspection (openstack baremetal introspection bulk start).
We need to remove the requirement of adding these lines to the json file and update the doc respectively.
Comment 4 Dan Macpherson 2015-10-14 21:47:27 EDT
Docs bug for this issue: https://bugzilla.redhat.com/show_bug.cgi?id=1271890
Comment 5 Mike Burns 2015-10-22 11:36:12 EDT
*** Bug 1274333 has been marked as a duplicate of this bug. ***
Comment 9 Alexander Chuzhoy 2016-02-26 16:14:38 EST
Verified:

Environment:
os-cloud-config-0.3.0-4.el7ost.noarch


Was able to successfully register (and later introspect) nodes using an instackenv.json file without cpu, arch,mem, disk

Here's the output from `ironic node-show <node id>` or such a node:
+------------------------+--------------------------------------------------------------+
| Property               | Value                                                        |
+------------------------+--------------------------------------------------------------+
| target_power_state     | None                                                         |
| extra                  | {}                                                           |
| last_error             | None                                                         |
| updated_at             | 2016-02-26T18:35:49+00:00                                    |
| maintenance_reason     | None                                                         |
| provision_state        | available                                                    |
| clean_step             | {}                                                           |
| uuid                   | c2c5f3a9-ec10-46ae-85ee-069140a9d51f                         |
| console_enabled        | False                                                        |
| target_provision_state | None                                                         |
| provision_updated_at   | None                                                         |
| maintenance            | False                                                        |
| inspection_started_at  | None                                                         |
| inspection_finished_at | None                                                         |
| power_state            | power off                                                    |
| driver                 | pxe_ipmitool                                                 |
| reservation            | None                                                         |
| properties             | {}                                                           |
| instance_uuid          | None                                                         |
| name                   | None                                                         |
| driver_info            | {u'ipmi_address': u'x.x.x.x', u'ipmi_username': u'root', |
|                        | u'ipmi_password': u'******'}                                 |
| created_at             | 2016-02-26T18:35:38+00:00                                    |
| driver_internal_info   | {}                                                           |
| chassis_uuid           |                                                              |
| instance_info          | {}                                                           |
+------------------------+--------------------------------------------------------------+
Comment 11 errata-xmlrpc 2016-04-07 17:39:10 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.