Bug 1274333 - Overcloud Environment File should not require CPU/RAM
Overcloud Environment File should not require CPU/RAM
Status: CLOSED DUPLICATE of bug 1255504
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-discoverd (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity low
: ---
: 7.0 (Kilo)
Assigned To: RHOS Maint
yeylon@redhat.com
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-22 09:44 EDT by John Fulton
Modified: 2016-04-18 02:56 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 11:36:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Fulton 2015-10-22 09:44:57 EDT
- Description of problem:

The introspection of nodes collects system information such as CPU count, memory, disk space, etc. Yet before we can do that we need to manually provide that information in a instackenv.json only to have it overwritten again. Users are putting garbage data in this file to make the parser happy and then counting on introspection to set it correctly. Rather than require them to supply that garbage data could the parser not require it and require only the data it needs to perform the introspection? 

- Version-Release number of selected component (if applicable):

[stack@undercloud ~]$ openstack --version
openstack 1.0.3
[stack@undercloud ~]$ 

- How reproducible: 
Deterministic

- Steps to Reproduce:
1. Create instackenv.json without cpu, memory, disk data
2. `openstack baremetal import --json instackenv.json`
3. Observe rejection because these fields are missing
4. Update instackenv.json with garbage data
5. `openstack baremetal import --json instackenv.json`
6. Perform instrospection and observe garbage data being overwritten anyway

- Actual results:
Unable to import Overcloud Environment File without CPU, RAM, etc. 

- Expected results:
Aable to import Overcloud Environment File without CPU, RAM, etc. because introspection will capture it later.
Comment 3 Mike Burns 2015-10-22 11:03:18 EDT

*** This bug has been marked as a duplicate of bug 1271890 ***
Comment 4 John Fulton 2015-10-22 11:30:55 EDT
Is this really a duplicate? 

bz1271890 is a docbug to change what the documentation says.  
bz1274333 (this) is a bug to change how the program works.
Comment 5 Mike Burns 2015-10-22 11:36:12 EDT
Sorry, wrong bug, I caught the doc clone, not the original code change bug.  Still a duplicate, though

*** This bug has been marked as a duplicate of bug 1255504 ***

Note You need to log in before you can comment on or make changes to this bug.