Bug 1255577 - Crackling sound from speakers on boot and application start (ThinkPad T450s)
Crackling sound from speakers on boot and application start (ThinkPad T450s)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
22
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-20 22:20 EDT by Bojan Smojver
Modified: 2016-05-26 15:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-26 15:35:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2015-08-20 22:20:41 EDT
Description of problem:
Since kernel 4.1.x was pushed to F-22, there is crackling sound coming out the the speakers on every boot. Same if I start Citrix Receiver 13.2, for instance. Some people would describe this as a popping sound.

Version-Release number of selected component (if applicable):
kernel-4.1.6-200.fc22.x86_64, but also other 4.1 kernels.

How reproducible:
Always.

Steps to Reproduce:
1. Boot F-22 on T450s.
2. Listen to the crackling/popping sound just before Gnome login comes up.

Actual results:
Unexpected sound from the speakers.

Expected results:
Should be silent and it was prior to kernel from 4.1 series.

Additional info:
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
        Subsystem: Lenovo Device 5034
        Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
        Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 0, Cache Line Size: 64 bytes
        Interrupt: pin A routed to IRQ 45
        Region 0: Memory at e1230000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
Comment 1 speedytux 2015-09-18 12:51:48 EDT
I wish to confirm the previous comment by Bojan Smojver.
But the issue on my T450s the issue start before selecting the kernel with grub 2.02 release 0.16.fc22
Comment 2 fedora_45sg 2015-10-02 13:58:17 EDT
I can confirm this behavior on latest Fedora 23 Beta Workstation.

I opened a bug-report https://bugzilla.redhat.com/show_bug.cgi?id=1268350

It's also listed on Launchpad, Debian BTS, and Suse's Bugtracker.

It seems that a Dev from Suse is working on this issue and is submitting a patch to the kernel. For further Information see my bug-report.

Also there is a temporary solution on https://bugzilla.suse.com/show_bug.cgi?id=943982#c8 for this issue.

Maybe this might help you.
Comment 3 fedora_45sg 2015-10-02 13:58:50 EDT
Maybe I should add that I have a T440s but behavior is the same.
Comment 4 Justin M. Forbes 2015-10-20 15:45:53 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 22 kernel bugs.

Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 23, and are still experiencing this issue, please change the version to Fedora 23.

If you experience different issues, please open a new bug report for those.
Comment 5 Bojan Smojver 2015-10-20 16:28:16 EDT
(In reply to Justin M. Forbes from comment #4)
 
> Fedora 22 has now been rebased to 4.2.3-200.fc22.  Please test this kernel
> update (or newer) and let us know if you issue has been resolved or if it is
> still present with the newer kernel.

Yes, still a problem in this kernel.
Comment 6 speedytux 2015-10-20 21:29:33 EDT
I confirm, the issue of is still here on Fedora Workstation 22, with Linux 4.2.3-200. Thank you very much for your interest and time!
Comment 7 Bojan Smojver 2015-11-01 23:06:29 EST
Seems fixed in 4.2.5-201.
Comment 8 Josh Boyer 2015-11-02 09:09:35 EST
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.