Bug 1255599 - Remove unwanted tests from volume-snapshot.t
Remove unwanted tests from volume-snapshot.t
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Atin Mukherjee
: Reopened
Depends On:
Blocks: 1255636
  Show dependency treegraph
 
Reported: 2015-08-21 01:28 EDT by Atin Mukherjee
Modified: 2016-06-16 09:33 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1255636 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:33:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Atin Mukherjee 2015-08-21 01:28:07 EDT
Description of problem:

volume-snapshot.t is failing spuriously because of having additional test cases which restarts glusterd. Currently glusterd doesn't have a mechanism to indicate that volumes handshaking has been completed or not, due to this even if the peer handshaking finishes and triggering a volume based command might end up in a corruption as volume handshaking is still in progress.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
intermittent

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Atin Mukherjee 2015-08-21 01:53:13 EDT
http://review.gluster.org/11972 posted for review
Comment 2 Anand Avati 2015-08-21 05:22:50 EDT
COMMIT: http://review.gluster.org/11972 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit aa1b166984657d53e68a2c4cbd16d2e46c12436b
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Fri Aug 21 10:54:39 2015 +0530

    tests: remove unwanted tests from volume-snapshot.t
    
    volume-snapshot.t failspuriously because of having additional test cases
    which restarts glusterd and they are really not needed as far as the test
    coverage is concerned. Currently glusterd doesn't have a mechanism to indicate
    that volumes handshaking has been completed or not, due to this even if the peer
    handshaking finishes and all the peers are back to the cluster there could be a
    case where any command which accesses the volume structure might end up in
    corruption as volume handshaking is still in progress. This is because of volume
    list is still not been made URCU protected.
    
    Change-Id: Id8669c22584384f988be5e0a5a0deca7708a277d
    BUG: 1255599
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: http://review.gluster.org/11972
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Raghavendra Talur <rtalur@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 3 Nagaprasad Sathyanarayana 2015-10-25 11:12:10 EDT
Fix for this BZ is already present in a GlusterFS release. You can find clone of this BZ, fixed in a GlusterFS release and closed. Hence closing this mainline BZ as well.
Comment 4 Niels de Vos 2016-06-16 09:33:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.