Bug 1255636 - Remove unwanted tests from volume-snapshot.t
Remove unwanted tests from volume-snapshot.t
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
3.7.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On: 1255599
Blocks:
  Show dependency treegraph
 
Reported: 2015-08-21 04:54 EDT by Avra Sengupta
Modified: 2015-09-09 05:40 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1255599
Environment:
Last Closed: 2015-09-09 05:40:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avra Sengupta 2015-08-21 04:54:23 EDT
+++ This bug was initially created as a clone of Bug #1255599 +++

Description of problem:

volume-snapshot.t is failing spuriously because of having additional test cases which restarts glusterd. Currently glusterd doesn't have a mechanism to indicate that volumes handshaking has been completed or not, due to this even if the peer handshaking finishes and triggering a volume based command might end up in a corruption as volume handshaking is still in progress.

Version-Release number of selected component (if applicable):
mainline

How reproducible:
intermittent

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Atin Mukherjee on 2015-08-21 01:53:13 EDT ---

http://review.gluster.org/11972 posted for review
Comment 1 Anand Avati 2015-08-21 04:55:31 EDT
REVIEW: http://review.gluster.org/11975 (tests: remove unwanted tests from volume-snapshot.t) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 2 Anand Avati 2015-08-26 01:16:01 EDT
REVIEW: http://review.gluster.org/11975 (tests: remove unwanted tests from volume-snapshot.t) posted (#2) for review on release-3.7 by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Kaushal 2015-09-09 05:40:21 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.4, please open a new bug report.

glusterfs-3.7.4 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/12496
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.