Bug 1255620 - [ALL-LANGS]- Tool tip in "Import Networks" shows nothing
[ALL-LANGS]- Tool tip in "Import Networks" shows nothing
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
All Linux
low Severity low (vote)
: ovirt-4.1.0-beta
: ---
Assigned To: Marcin Mirecki
Michael Burman
:
Depends On:
Blocks: 1314375
  Show dependency treegraph
 
Reported: 2015-08-21 04:06 EDT by Satyabrata Maitra
Modified: 2017-02-15 10:04 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-15 10:04:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.1+
rule-engine: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
tool tip screen shot (77.75 KB, image/png)
2015-08-21 04:06 EDT, Satyabrata Maitra
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 68438 master MERGED webadmin: Restore "Import Networks" "Allow All" header and improve tooltip 2016-12-19 07:37 EST
oVirt gerrit 68727 ovirt-engine-4.1 MERGED webadmin: Restore "Import Networks" "Allow All" header and improve tooltip 2016-12-19 10:59 EST

  None (edit)
Description Satyabrata Maitra 2015-08-21 04:06:47 EDT
Created attachment 1065474 [details]
tool tip screen shot

Description of problem:
In "Import Networks" window, "Networks to Import" section, the tool tip shows nothing when mouse over.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.6.0-0.11.master.el6

How reproducible:
Always

Steps to Reproduce:
1. Login in RHEVM admin portal in any locale 
2. Navigate tab : Networks --> Import
3. Observe the tool tip in "Networks to Import" Section as pointed in the screen 
   shot attached.

Actual results:
This tool tip shows nothing when mouse over or clicked.

Expected results:
It should show the relevant information or open the guide in different tab in web browser being used. in case this tool tip is not needed, should be removed.

Additional info:
Screen shot attached pointed out with red arrow and comment.
Comment 1 Einav Cohen 2015-08-22 15:54:03 EDT
reproduced on 'master'. 

additional things that i observed after opening the 'Import' dialog:

- closing the dialog using 'cancel' is impossible - clicking the 'cancel' button does nothing (closing the dialog via the 'x' button on the upper-right corner is possible). 

- after closing the dialog: opening a dialog in the 'Networks' main-tab is impossible; I tried 'New' and 'Import' - both of these buttons do not respond. 
Navigating to another main-tab (e.g. 'Storage') and back to the 'Networks' main-tab doesn't help - the 'New'/'Import' buttons are still not responsive. 
only refreshing the entire page helps.
Comment 2 Red Hat Bugzilla Rules Engine 2015-11-30 15:57:55 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 3 Krishna Babu K 2015-12-10 03:52:26 EST
(In reply to Einav Cohen from comment #1)
> reproduced on 'master'. 
> 
> additional things that i observed after opening the 'Import' dialog:
> 
> - closing the dialog using 'cancel' is impossible - clicking the 'cancel'
> button does nothing (closing the dialog via the 'x' button on the
> upper-right corner is possible). 
> 
> - after closing the dialog: opening a dialog in the 'Networks' main-tab is
> impossible; I tried 'New' and 'Import' - both of these buttons do not
> respond. 
> Navigating to another main-tab (e.g. 'Storage') and back to the 'Networks'
> main-tab doesn't help - the 'New'/'Import' buttons are still not responsive. 
> only refreshing the entire page helps.

 #1256250 reporting the same issue regarding 'cancel' button, Maybe the fix could be same for the both.
Comment 4 Sandro Bonazzola 2016-05-02 06:09:10 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 5 Yaniv Lavi 2016-05-23 09:24:43 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 6 Yaniv Lavi 2016-05-23 09:25:57 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 7 Marcin Mirecki 2016-12-13 09:12:13 EST
Current state:

- The tooltip shows: "Allow All" - this is not very helpful, will change to: "Allow all users to access the imported network"

- The lable in the dialog does not display properly.
Comment 8 Marcin Mirecki 2016-12-14 04:48:06 EST
- Restored the label for the checkbox
- Changed tooltip message to: Allow all users to access the network

The issue with closing the dialog was solved in a separate bug some time ago.
Comment 9 Michael Burman 2016-12-28 01:29:06 EST
Verified on - 4.1.0-0.3.beta2.el7

Note You need to log in before you can comment on or make changes to this bug.