Bug 1314375 - [RFE] - Provide external network partners API
[RFE] - Provide external network partners API
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: RFEs (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.0.0-beta
: 4.0.0
Assigned To: Marcin Mirecki
Meni Yakove
: FutureFeature
Depends On: 1216991 1255620 1314371 1316021 1317581 1318543
Blocks: 1353388
  Show dependency treegraph
 
Reported: 2016-03-03 08:20 EST by Yaniv Lavi
Modified: 2016-07-26 00:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Previously, to use external network providers, only OpenStack Networking (Neutron) is supported. With this update, any external network provider that implements the OpenStack Neutron REST API can be added to Red Hat Virtualization. The external network provider does not use the Neutron agent as the virtual interface driver implementation on the host. Instead, the virtual interface driver should be provided by the implementer of the external network provider. A read-only feature is also available to prevent users from modifying the external network provider from the Manager.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-05 03:41:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.0+
ylavi: priority_rfe_tracking+
myakove: testing_plan_complete+
ylavi: planning_ack+
danken: devel_ack+
myakove: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54740 master MERGED webadmin: Add External Network Provider to list of providers 2016-04-12 03:41 EDT
oVirt gerrit 54825 master MERGED webadmin: Adding UI read-only feature for external networks 2016-04-12 05:04 EDT
oVirt gerrit 55006 master MERGED webadmin: Read only feature for external provider subnets 2016-04-14 05:16 EDT
oVirt gerrit 55076 master MERGED engine: Validate external network modifications against read-only attribute 2016-04-14 05:23 EDT
oVirt gerrit 55084 master MERGED webadmin: Read only feature for removing external networks 2016-04-14 05:24 EDT
oVirt gerrit 55106 master MERGED webadmin: Read only feature for adding external networks 2016-04-14 05:25 EDT
oVirt gerrit 55263 master MERGED engine: Adding read-only check in ExternalNetworkProviderProxy 2016-04-14 05:30 EDT
oVirt gerrit 55404 master MERGED engine: Add External Network Provider to list of providers 2016-04-11 12:09 EDT
oVirt gerrit 55430 master MERGED engine: create base class for network provider proxies: BaseNetworkProviderProxy 2016-04-11 09:12 EDT
oVirt gerrit 55431 master MERGED engine: Adding UI read-only feature for external networks 2016-04-12 05:03 EDT
oVirt gerrit 56590 master MERGED engine: Removing ExternalNetwokProviderProperties 2016-05-01 02:52 EDT
oVirt gerrit 56591 master MERGED engine: Changing OpenstackNetworkProviderProperties read-only from Boolean to boolean 2016-05-10 03:29 EDT
oVirt gerrit 56592 master MERGED engine: External providers must support authentication with and without tenant name 2016-05-01 02:59 EDT
oVirt gerrit 56593 master MERGED webadmin: Make tenant field available for external providers 2016-05-01 03:50 EDT
oVirt gerrit 56594 master MERGED engine: Add query fetching providers by multiple provider types 2016-05-10 03:25 EDT
oVirt gerrit 56595 master MERGED webadmin: Adding read only option to openstack providers 2016-05-10 03:28 EDT
oVirt gerrit 56612 master MERGED restapi: Adding readOnly property to NetworkProvider 2016-05-10 03:26 EDT
oVirt gerrit 56712 master NEW restapi: Adding type to OpenstackNetworkProvider 2016-05-09 09:49 EDT
oVirt gerrit 57082 master MERGED webadmin: Changing network provider read-only default value to true 2016-05-10 04:05 EDT
oVirt gerrit 57092 master MERGED engine: Apply tenant id for all networks providers 2016-05-10 04:06 EDT
oVirt gerrit 57093 master MERGED webadmin: Display only openstack providers when adding host 2016-05-10 04:08 EDT

  None (edit)
Description Yaniv Lavi 2016-03-03 08:20:31 EST
Description of problem:
Currently the Openstack Neutron integration allows oVirt to integrate with Openstack Neutron. This purpose of this feature is to simplify this to make it easier to add support for networks supplied by external providers. The providers will be able to provide networks using a simplified Neutron-like API.

Many organizations use centralized network management systems to handle all their networking, and would like them to manage the network topology of their oVirt environments. Currently the only option of using external networks in oVirt is to used the OpenStack Neutron integration, which allows the import of OpenStack Neutron networks and the provisioning of VM's connected to these networks. This feature is however very specific to OpenStack Neutron. We would like to extend this API to other external network providers, by making it simpler, more general and less dependant on OpenStack Neutron features. The result should be an API over which oVirt can communicate with external network management systems, and use the networks defined in them in provisioned VMs.
Comment 1 Dan Kenigsberg 2016-03-27 07:42:44 EDT
Marcin, please add relevant patches to this RFE.
Comment 2 Sandro Bonazzola 2016-05-02 05:49:58 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 3 Michael Burman 2016-06-29 04:35:47 EDT
Verified on - 4.0.0.6-0.1.el7ev and vdsm-4.18.4-2.el7ev.x86_64 using Marcin's latest mock-provider and vif-driver RPMs.

vdsmdummy-driver-0-1.noarch
provider-mock-0-1.noarch 

- NOTE, each provider should provide an information about the required iptables rule/port.
Comment 4 Sandro Bonazzola 2016-07-05 03:41:14 EDT
oVirt 4.0.0 has been released, closing current release.

Note You need to log in before you can comment on or make changes to this bug.