Bug 1255638 - [dialog] support unicode output
[dialog] support unicode output
Status: CLOSED CURRENTRELEASE
Product: otopi
Classification: oVirt
Component: Plugins.dialog (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.0-rc
: 1.4.0
Assigned To: Yaniv Kaul
Gonza
:
: 1257047 1263160 (view as bug list)
Depends On:
Blocks: 1262550
  Show dependency treegraph
 
Reported: 2015-08-21 04:56 EDT by David Jaša
Modified: 2016-02-10 07:51 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Unicode character within otopi human dialog caused error during string processing. Consequence: In most cases unicode string could not be accepted. Fix: Modify the method otopi process input and log to accept unicode string correctly. Result: User can enter unicode text.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-10 07:51:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: planning_ack+
rule-engine: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45200 master MERGED core: support unicode output Never
oVirt gerrit 45990 master MERGED core: reorder unicode str() construction Never
oVirt gerrit 46097 master MERGED core: fallback unicode conversion if exception Never

  None (edit)
Description David Jaša 2015-08-21 04:56:11 EDT
Description of problem:
unicode in e.g. surname makes ovirt-engine-extension-aaa-ldap-setup crash on Search during Setup validation

Version-Release number of selected component (if applicable):
ovirt-engine-extension-aaa-ldap-setup-1.1.0-0.0.master.el6ev.noarch / RHEV 3.6.0-10

How reproducible:
always

Steps to Reproduce:
1. add a domain with unicode-formatted names using -setup command
2. in Setup Validation phase, perform a search for such a name with unicode in the name
3.

Actual results:
[ ERROR ] Failed to execute stage 'Setup validation': 'ascii' codec can't encode character u'\u0161' in position 65: ordinal not in range(128)

Expected results:
search completes successfully

Additional info:
only -setup command is affected, the users work in engine correctly when the domain is added using configuration files manually
Comment 1 Alon Bar-Lev 2015-08-21 05:00:47 EDT
please stop opening downstream bugs for a component/issue that is not downstream specific.
Comment 2 Alon Bar-Lev 2015-08-21 05:01:34 EDT
setup log, please.
Comment 5 Alon Bar-Lev 2015-08-21 12:09:05 EDT
this is interesting how we did not see this before, probably most people use plain ascii.
Comment 6 Alon Bar-Lev 2015-08-29 12:58:13 EDT
*** Bug 1257047 has been marked as a duplicate of this bug. ***
Comment 7 Ivan Bulatovic 2015-09-15 19:15:56 EDT
*** Bug 1263160 has been marked as a duplicate of this bug. ***
Comment 9 Gonza 2016-01-28 04:30:14 EST
Verified with:
ovirt-engine-extension-aaa-ldap-setup-1.1.2-1.el6.noarch

...
2016-01-28 10:26:57 INFO    AAA_AUTHZ_PRINCIPAL_NAME: my_test
2016-01-28 10:26:57 INFO    AAA_AUTHZ_PRINCIPAL_FIRST_NAME: Čeněk
...

Note You need to log in before you can comment on or make changes to this bug.